Gaming Service issue - Again - it's an absolute disaster

Which version?

Windows 11 is not suitable for Simmers?! Seriously?! I’m sorry, but I can’t believe that at all. That would be completely absurd. On all support pages I find the note that you should update to the latest Windows version. Windows 10 is required as a minimum OS for MSFS.
here: W11 home, 21H2, built 22000.613

1 Like

Not recommended for simmer is nonsense. I was actually going to respond to this, but I think the statement is wrong as well. I currently play all my games under Win11 21H2 (Build 22000.613) incl. MSFS2020, DCS, IL2-BOS without CTDs. Hell, both of my 2TB M.2 NVMe’s are almost full and all games run just as well as they did on Windows 10.

1 Like

Yeah I run win11 on an unsupported machine and it runs all the games I have just fine. Maybe I loose 1 or 2 fps in a game here and there but still nothing to cry about.

Only problem I have with win 11 is the future as reported by the online press as to ‘new’ features that are getting introduced. -shudders- :wink:

Agreed, Win10 or Win11 doesn’t make a difference. Both are optimized for gaming. Saying that Win11 isn’t recommended just makes you look foolish. I played FS2020 on both Win10 and Win11 and Gaming Services failed on both versions. And I highly doubt that the build of Windows has an impact on something like this.
But… here: Win11 Pro 21h2 build, 22000.652

Recommended OS - Windows 10


So help him :wink:

Sure, Windows 10 was recommended when the sim was first launched because Windows 11 wasn’t out yet. And as your other reply to @AlexE75 instead of saying “So help him” can you maybe offer some constructive support as opposed to just asking people what version of Windows they have and then saying that it’s not recommended. That doesn’t help anyone.

1 Like

Look, we are all passionate about aviation one way or another, that’s why we bought FS2020. Instead of asking arbitrary questions that don’t really offer any help, why not put out heads together to try to solve this. I’m sure if we all keep pushing, eventually, the right person at Microsoft/Xbox will notice and solve this issue once and for all.

I’ve been running Windows 11 pretty much since it was released, and I’ve not had any issues with it that I could attribute to the OS.


You can’t just say that someone is wrong and not offer a solution or provide an answer. That doesn’t help resolve the issue. Just leads to more questions. Most of us have already tried all the basic troubleshooting like the ones in your second link. We wouldn’t be on this forum if they worked.


Windows 11 latest build 22000.652 / /dated 2022-04-25

The issue of not being able to enjoy FS2020, is frustrating for many of us suffering from this bug, but this should not be the reason for tensions to flare up on the forum.
I hope we can continue to provide constructive feedback and support each other while searching for the solution.

Here is more technical info I pulled from Windows Logs:

When attempting to start FS2020 (or any other game purchased from MS Store) the GamingServices .exe tries to load two drivers on startup: xvdd.inf (.sys) and gameflt.inf (.sys). xvdd.inf loads normally and installs a virtual storage appliance used by Xbox gaming service: SWD\XvddEnum\XvddRootDevice_Instance (it can be located using pnputil.exe /enum-devices /drivers).

Instance ID: SWD\XvddEnum\XvddRootDevice_Instance
Device Description: Microsoft Gaming Driver
Class Name: Unknown
Class GUID: Unknown
Manufacturer Name: Unknown
Status: Problem
Problem Code: 28 (0x1C) [CM_PROB_FAILED_INSTALL]
Problem Status: 0xC0000490

Clearly, there is an issue with loading xvdd.inf

As for gameflt.inf, pnputil.exe is unable to locate the driver, which explains Windows Services Error System error 2 … system cannot find the file specified.

Digging deeper into C:\Windows\INF\ .log you can see the following GamingServices .exe attempts to install gameflt.inf (AMD64 specific), Windows thinks that an updated version has already been installed and won’t continue. This appears to be the root cause of the issue.

[Device Install (DiInstallDriver) - C:\Program Files\WindowsApps\Microsoft.GamingServices_3.63.31001.0_x64__8wekyb3d8bbwe\drivers\gameflt.inf]
Section start 2022/04/26 09:04:02.821
cmd: “C:\Program Files\WindowsApps\Microsoft.GamingServices_3.63.31001.0_x64__8wekyb3d8bbwe\GamingServices.exe”
ndv: Flags: 0x00000000
ndv: INF path: C:\Program Files\WindowsApps\Microsoft.GamingServices_3.63.31001.0_x64__8wekyb3d8bbwe\drivers\gameflt.inf
dvs: {DrvSetupInstallDriver - C:\Program Files\WindowsApps\Microsoft.GamingServices_3.63.31001.0_x64__8wekyb3d8bbwe\drivers\gameflt.inf}
dvs: Flags: 0x00000000
dvs: {Driver Setup Import Driver Package: C:\Program Files\WindowsApps\Microsoft.GamingServices_3.63.31001.0_x64__8wekyb3d8bbwe\drivers\gameflt.inf} 09:04:02.823
inf: Driver package is fully isolated.
dvs: Driver Package:
dvs: Outcome - Already Imported
dvs: Driver INF - gameflt.inf (oem353.inf)
dvs: Class GUID - {d546500a-2aeb-45f6-9482-f4b1799c3177}
dvs: Driver Version - 03/21/2022,10.0.22004.2
dvs: {Driver Setup Import Driver Package - exit (0x00000000)} 09:04:02.831
inf: Driver package is fully isolated.
ump: {Plug and Play Service: Driver Install for C:\WINDOWS\System32\DriverStore\FileRepository\gameflt.inf_amd64_4fb6ff83cee708c3\gameflt.inf}
pol: {Driver package policy check} 09:04:02.839
pol: {Driver package policy check - exit(0x00000000)} 09:04:02.839
sto: {Configure Driver Package: C:\WINDOWS\System32\DriverStore\FileRepository\gameflt.inf_amd64_4fb6ff83cee708c3\gameflt.inf}
inf: Class GUID = {d546500a-2aeb-45f6-9482-f4b1799c3177}
inf: Class Options = Configurable
inf: {Configure Driver: Game mini-filter driver}
inf: Section Name = DefaultInstall.NTamd64
inf: Driver Type = Primitive
sto: Finding all published driver package versions
! sto: Skipping driver package superceded by newer driver package ‘’.
inf: {Configure Driver: exit(0x00000000)}
flq: {FILE_QUEUE_COMMIT} 09:04:02.847
flq: {FILE_QUEUE_COMMIT - exit(0x00000000)} 09:04:02.848
sto: {Configure Driver Package: exit(0x00000000)}
ump: {Plug and Play Service: Driver Install exit(00000000)}
dvs: {DrvSetupInstallDriver - exit(00000000)}
<<< Section end 2022/04/26 09:04:02.851
<<< [Exit status: SUCCESS]

It seems that there is some kind of bug in Windows, and when trying to install AMD specific driver. The issue is definitely related to Xbox services integration with the Windows platform.
I wish there was a better way to debug the Gaming Service startup process.
Speaking with Microsoft support last night, they deny this to be a widespread issue, but clearly, a quick Google search proves otherwise.

I only understood 3 things from your post:

  1. Be quiet and don’t make any loud noises here, even if you are at maximum annoyance
  2. Windows screwed up twice: Xbox integration and Gaming service start up process
  3. Windows continues to ignore the problem

Since even squid can learn, I realized that there is no solution. It is fatal that the largest software manufacturer is able to produce a great product but ultimately fails due to the complexity it creates itself.

Is there meanwhile a solution to this problem?

If you ask such a question then I think that you are still at the very beginning of the problem. Good luck with the next steps.

Yes - that is true - and nothing that was proposed in this thread helped.

Very frustrating - its always 2-4h of work after an update to get this sim/game running. This time with no solution so far.

Not for me, and I’m sure many others. I’m sure I’m equally mystified why some folks keep having threes problems as those who don’t understand why I don’t.

I update either in the Store, or the Xbox app, I launch the sim to let it download its updates, then I fly. No muss, no fuss.

I have to wonder how many of these issues could be attributed to the OS rather than the sim.

I would also be interested to know if those having Gaming Services issues have any other MS Store games, and whether those work correctly or not.

“I update either in the Store, or the Xbox app”

Unfortunately this doesn’t always work, that’s exactly the problem. All recipes published here to solve the problem assume that a MS Store update for Xbox and Gaming Service is not possible or is not carried out correctly. Therefore, manipulations in the registry are required to force the update. (delete and restore) But even these manipulations are not always successful, for whatever reason.

“I launch the sim to let it download its updates”

Please note, that you HAVE TO do any MSFS update in any case, otherwise the game won’t start.

I know, for reasons I outlined before. If you think of MSFS as an MMO, it will make more sense to you.