OpenXR Toolkit (upscaling, world scale, hand tracking...) - Release thread

[OXRTK] 2022-02-06 03:19:12 +0100: dllHome is “C:\Program Files\OpenXR-Toolkit”
[OXRTK] 2022-02-06 03:19:12 +0100: XR_APILAYER_NOVENDOR_toolkit layer (Beta-2) is active
[OXRTK] 2022-02-06 03:19:12 +0100: Using OpenXR runtime Windows Mixed Reality Runtime 109.2111.23003
[OXRTK] 2022-02-06 03:19:12 +0100: Ignoring XR_MSFT_hand_interaction for Windows Mixed Reality Runtime 109.2111.23003
[OXRTK] 2022-02-06 03:19:32 +0100: dllHome is “C:\Program Files\OpenXR-Toolkit”
[OXRTK] 2022-02-06 03:19:32 +0100: XR_APILAYER_NOVENDOR_toolkit layer (Beta-2) is active
[OXRTK] 2022-02-06 03:19:32 +0100: Using OpenXR runtime Windows Mixed Reality Runtime 109.2111.23003
[OXRTK] 2022-02-06 03:19:32 +0100: Ignoring XR_MSFT_hand_interaction for Windows Mixed Reality Runtime 109.2111.23003

That’s all my log said :confused: I’m really confused. Now uninstalling had no impact, still freezing. I can’t really get what’s going on under the hood :smiley:

It seems a lot of people are missing the Eye Offset (think that’s the name, not at my PC) in the options menu, change that and you can “merge” the two menus into one and voila, easy to read.

4 Likes

I’m also PPL and for me C172/C152 cockpits are way to small. This is subjective and depends on your IPD. Fortunately with the toolkit we can finally set it individually.

5 Likes

Thank you for the tip on changing the VR post processing “sharpening” value in the Usercfg file to “0”. Much better and resulted in a little bit headroom.

I’d like to ammend that my system now averages 34 fps instead of the earlier reported 30 fps. After re-testing I descided to keep toolkit resolution at 80% but increased toolkit sharpening a bit to 35%. Also in MSFS I added bloom effect, without much apparent impact on fps. With 34fps, I like that it gives a tad of headroom when things in sim get busier compared to 30fps before.

All in all it is nicely balanced between graphics and average VR performance in various MSFS (still motion smoothing disabled in OpenXR).

Mucho kudos! :slight_smile:

1 Like

FSR or NIS?

2 Likes

As asked, here are my MSFS setting for using my HP Reverb G2, using 100% in-game scaling


Nvidia driver settings: 40 max fps, low latency mode on, power management prefer max. OXR at 100% scaling.

Running my i7 10700k at 4.9 Ghz all core, 2x16 GB DDR at 4000 16-17-17-36, feeding an evga rtx 3080 ti ftw3 ultra in overclock mode.

As mentioned, running OpenXR_toolkit FSR 90% sharpening at 80% scaling and 85% world scale.

I get a near solid 40 fps with the above. The only time it dips occasionally and temporarily into the upper 30’s is when over metropolitan areas. All my flying is below 15k ft.

I have to recant my claim about no AA/shimmering of building and trees. On my climb out right after takeoff, there is a band of distant ground objects seen at about a 10 to 30 degree aspect angle that are a shimmering mess as I climb. Once the above that aspect angle everything clears up, including all ground objects for as far as I can see. BTW, I have excellent vision and hate jaggies with a passion. VR has been an exercise in visual clarity compromises for me; I’ve come to the place where the VR “whole” experience is DEFINITELY much better than the sum of its parts.

Really looking forward to when (if?) MSFS implements DLSS for VR. That will be a grand day indeed!

Mods, please excuse my indulgence with this post.

1 Like

you mean FSR 90% and 80 sharpening?

FSR with 90% sharpen and 80% scaling. Updated my post to note this.

Try turning off windows game mode and/or HAGS if you have either of them turned on.

Regarding the shimmering: Yes, what you describe is the big issue I have. I believe the reason it clears up once you climb further is because the buildings are simply no longer rendered and the scenery switches to 2D (but it still looks normal as you are now at sufficient altitude).

1 Like

Amen to that.
Also OpenXR 250% and target your final resolution in the Toolkit. I’m at 30xx at the moment
Clarity I’be never seen before in my G2.
Remember to disable Sharpness in config file.

Cheers!

Just picked up a G2 on Friday…it’s my first VR experience ever and I’m loving it so far. I also love tweaking to get everything “perfect.”, so I had some serious fun this weekend.

So far, performance has been good…pretty much exactly what I expected. Mostly 30-40 fps with smooth performance. Running a 3080, Ryzen 3700x, 32 GB Ram.

My biggest nitpick right now is overall clarity. I’m getting more blur than I thought I would, especially at a distance and to my peripheries. Again, this is my first ever VR experience so I’m not sure if this is just simply a VR limitation at the moment, or something that can be improved with further tweaking. I also noticed I’m fiddling with the headset quite a bit while in flight in order to improve the clarity. So it could also be a matter of just finding the correct headset adjustment for my head.

Current Toolkit Settings @100% OpenXR and 100% In-game :
FSR: 85%
Sharpening: 100% (I find this at max helps eliminate some of the blur, but I’m not sure if it’s just placebo?) Also, I haven’t disabled the default sharpening in the .config file…It seems like I should do that?
World Scale: 85%
Hags: ON
MR: OFF

OpenXR Toolkit:
NIS, Resolution 80%, Sharpness 35%, Worldscale ~62mm

OpenXR Dev:
Resolution 100%, Motion reprojection Disabled

MSFS \ Graphics \ VR:
Resolution 100%
Mixed medium to high, aa TAA, shadows 768/low/off, anisotropic 8x

MSFS Usercfg \ VR Post processing:
Sharpness 0

NVIDIA driver:
511.65 (Feb, 1, 2022)

System:
Ryzen 3700X @4.3Ghz
GSkill 32GB @3600-CL15 (OC)
Asus X570-E Gaming
Asus RTX 2080 Super OC
Crucial MX500 1TB
W10 Pro DX11

VR:
Reverb G2, v.1.

~34fps average, and ~27-28 fps in the more significant busy conditions, happens only incidental IMHO.

Note: will test it again, but was not able to get any better results (FPS, clarity) with FSR, so sticking to NIS

Try these settings, the clarity is amazing.

3080Ti Overclocked +800, +110
i7 7700K, 4,9Ghz Overclocked
32 Ram
Reverb G2
HAGS On
Game mode Off
Nvidia 511.66
Anisotropic Filtering 16x in Nvidia settings, off in sim.

Open XR 250%
Motion Off

FSR 65 (3250x3180)
Sharp 100
World Scale 94

Sharpness in config file Off.
This made a huge difference.

30 fps in flight, 26fps on the ground.
Clouds Ultra, LOD 300, Resolution 100, the rest Ultra except, Trees High, Grass and Bushes Mid, Ambient Occlusion High and Contact Shadows High.

Cool thanks for the tips. I will give these a shot tonight and report back!

I thought I saw something earlier in this thread about Open XR needing to be at 100% for the Toolkit FSR to function properly…but I may just be misremembering.

Consider bringing the lenses closer to your eyes. Search for Frankenfov or Frankenfov Deluxe gaskets mods. Also with time your brain will adapt a bit to the reletively narrow sweet spot of the G2.

You could try this to get an idea what amount of clarity the g2 is capable of. Set both OXR scale 130 and MSFS scale to 130 (config sharpen 1) and disable OXR toolkit. It will not be playable but you can compare to your toolkit experiments.

You dont mention your ingame render scale. I assume its 100?

So i’ve been using the OpenXR toolkit with MR on and while it works and provides increased clarity, i thought id try it with MR off.

It seems to make a much bigger difference with MR off vs on. (I hope that makes sense) I’m going to try and go back to not using MR anymore. I was in the FBW a320 and was blown away to see 40fps. I had my LODS at 65 as that’s what was required to use MR without too many hiccups.

The world scale and prediction dampening are first class additions.

My 3080, Reverb G2, i5 9600, 32gb ram
OXR 100 TAA 100 FSR 80 sharpening 90
Dampening -20%
World scale 90% (aircraft dependent)

Still tweaking things but thanks @mbucchia @CptLucky8 and others for your work on this!

2 Likes

Thanks for the tip…I’ll try that out!