OpenXR Toolkit (upscaling, world scale, hand tracking...) - Release thread

banner

Hi everyone!

The OpenXR Toolkit is the continuation of the work I started on this thread, then that thread, and finally that thread.

I’m creating a new thread here because the project has been morphing quite a lot in the last few weeks and is no longer limited to hand tracking and NIS upscaling. Please try to keep this thread on topic.

Since then, I have been joined by @CptLucky8, and together we are bringing a general set of features to improve your VR experience:

  • The original upscaling feature returns, and we now offer the choice between the NIS algorithm and the FSR algorithm, and it works with both DX11 and DX12;
  • We’re addressing some of the top wanted feature requests such as support for custom world scale, brightness/contrast/saturation control and the sunglasses mode;
  • Some features like the shaking reduction (formerly prediction dampening) help mitigate some of the known issues like the cockpit shaking;
  • Some advanced features such as Foveated Rendering are added and give you a boost in performance with very little quality loss. With addition of eye tracking in version 1.1, Flight Simulator 2020 is now the first AAA title to support Foveated Rendering!!
  • The Ultraleap/Quest 2 hand tracking to VR controller inputs simulation - feature that started it all - is now more usable and advanced than ever.

We’ve also been joined by @FarFutureFox and @GroovyOkra to bring some awesome user experience support, through a new in-VR menu and some (on-going) rewrite of the Companion app.

I also want to thank @RPthreenine for creating a logo for the project!

The full instructions and download links are on our website:

Latest version is 1.1.2 (please check for this number during installation).

@PIESKYTOURS has published videos to help you everyone getting started with the project (check out more of them on his channel):

In addition to the quickstart resources, every feature is thoroughly documented and we have been writing a guide for tweaking Flight Simulator.

We are not going to stop here! Check out our roadmap to see what we are trying to bring to you next.

Having issues? Head to the FAQ and see the troubleshooting guide.

Per request from the community, we have also created a Discord server for the project, where you can discuss the project in general, ask for support, or share you settings.

Please try to keep this thread on topic. We are discussing the OpenXR Toolkit.

81 Likes

Thank you very much for this nice piece of software!

I’ll would like to congrat you first for this unvaluable tool!
FSR is again a step beyond in terms of quality and performance.
World Scale works perfectly :slight_smile:

So, if I want to try this out, do I need to download anything else to use the OpenXR Toolkit, or is everything I need part of the Toolkit? The video mentions the OpenXR Developer Tool which is something I’m not familiar with.

This part is only for Windows Mixed Reality (eg: HP Reverb). If you are using Oculus/Steam or other, you need to find the corresponding setting (render scale). You can also just ignore this part and maybe the default render scale setting will just work OK for you.

OK, got it… Yep, I use a Quest 2 so have not run into the OpenXR Developer Tool. Thank you! I’ll probably wait until after the World Update on Monday to limit the amount of changes over a short period of time. :smile:

:wink: “Invaluable!”

Mattheiu? Are you tired of being called a legend yet? Even if you are, let me repeat it, you sir are an absolute LEGEND.
It is brilliant. Thank you, Thank you, Thank you.
I have a 3070ti
Sim render scale 80%
OXR 150%
FSR 60%
and the visuals are the best I’ve ever experienced.
LEGEND

9 Likes

Working great so far, Matthieu! Will experiment more, though NIS and FSR are working just fine! Thanks and I hope you were able to get some sleep!

1 Like

Oups, my so bad english :blush:

1 Like

Just incase anyone suffers this; I was getting an install error initially when trying to install the latest update, it was looking for a ConfigUI item and failing. What I had done was uninstall the old version first then tried installing the new version, so I reinstalled the old version and then the install worked.

Once it installed it worked well on the desktop app, in sim with my Reverb G2 I had “double-vision” of the config screen but adjusting the offset all the way eventually merged the two screens and all is well.

A quick go and everything seems to work great, will play with it more later, as ever a big thank you to the Devs working on this project :slightly_smiling_face:

1 Like

Thank you forks

  • Please remember to credit @CptLucky8 as well - things like FSR are 100% his work!!

  • Sorry about the issues for AMD users - working on it now (but without an AMD card myself). It looks like DX12 works fine with AMD cards, so gotta figure out how to make it work with DX11 now.

12 Likes

Question, do I need to have the OpenXR bit set to 100%? I felt like with the prior program setting it to 80% worked better for my system.

Whatever works better for you yes. For clarity you’d want to try to raise this value back to 100% or more, but if you have experimented and 80% if best then I’d say stick with it!

Just went through the website. Had some really great info on features and setup. Thanks again for this amazing tool. :+1:t5:

Paging @mbucchia and @CptLucky8. You guys really need to add a donate button to that website…

15 Likes

Great Job @mbucchia thx for this it is amazing.

Anyone has an Experience what the right World Scale for A32N is i think 115 looks good but i never
sit in a real one.

2 Likes

Thanks so much for this app, I finally got rid of cockpit shaking, so it is much appreciated.
pH

1 Like

@mbucchia Great work! One note from testing the pre-release: when I brought up the menu in a testing OpenXR scene that you can bring up from OpenXR Developer Tools - I too saw brocken characters that were unreadable. But it loaded fine in MSFS. I didn’t mention it in private conversation because I thtough it’s not important, maybe it wasn’t supposed to work there, but as I see people are seeing this problem in MSFS, so maybe at least it would be a good way to reproduce the problem on NVIDIA card.

1 Like

Do you have MFAA enabled in the Nvidia driver?

1 Like