Sim crashes when zooming in at the worldmap

Yes, it works on the world map, but not necessarily for CTD when you launch a flight (for me, 25% CTD when the flight loads at around 80%). To prevent CTD on the world map and at flight launch, disabling bing data seems to be the best solution (at least for me)

1 Like

Ok. I almost never had the 25% crashes you describe. This makes a 100% Fix for me. Your experience may differ.

Let’s summarize: This “World map disabling the weather Fix” disables all CTDs I have wile in the map. It doesn’t mean that it is meant to cure all CTDs-
It is not a Fix. It is a just go around. Furthermore, it disables just another feature that was working once, just to keep this simulation working.

The Topic is: “Sim crashes when zooming in at the worldmap”

I’m just happy that I can use the map again without CTD, It was so frustrating the last 3 weeks (since SU 13) to unplug the Ethernet cable to start a flight.

2 Likes

It’s less frequent but it sometimes happens to me in flight, generally before the approach.

1 Like

Internet Connection 10.23
Yes, here’s my speed test, fibre connection (France)

I’ve just submitted a ticket with the DxDiag/ MS Info/ Internet connection speed and other things. Hoping the problem is resolved quickly :')

Same issue here, 1Gbps net connection (really, can easily do around 120-150Mbits even with MSFS downloads and 700-800Mbits with contents having better bandwidth) so I can also confirm internet connection is not an issue for this bug. Started happening a few weeks ago.

Same issue here that has started recently. I didn’t have it before, but now whenever I zoom in on the world map when trying to select my departure airport, the sim CTDs.

That’s now 14 out of 14 members who have responded indicating that they have the issue and have stated that they have high speed (fibre) internet connections.

Remember to fill in a zendesk ticket as requested here →

However despite the moderator stating that the ticket will ask you for your connection details I found that not to be the case when I filled in my ticket (as did another poster). So it may be useful to include your connection details in the description box that you do fill in. I can’t help but feel this is important to the issue.

1 Like

The situation is definitely getting worse, for me it started about two weeks ago, never had the issue before. Some days I was lucky, but now it’s a nightmare, almost all my tries with Bing data and satellite view on world map make my sim CTD.

Yesterday it even happened just before approaching my arrival airport (KMCI).

Funny thing, I just remember that my Bing data were deactivated after the SU13 update, maybe Asobo already knew it was the best thing to do ^^

Same here. I never had CTDs for months until last week. The world map and in-game CTDs seem to be related. I also can’t slew because I get instant CTDs. Prior to last week, I could slew at 8x without any issues.

Unfortunately no, it’s not a hotfix, the bug still exists without weather on the map - at least for me.

New information from support following my ticket and exchanges with support.
The bug will now be passed on to the QA teams.

I realize that the forum is useful, but that it’s necessary to open tickets and prove that they exist in vanilla mode. So the bug is handled by the QA.

Next step: Hope the QA can reproduce the bug.


Support message

Your report will now go through the Bugs and Issues Review Process and will be first examined by the QA team before reaching the development teams. We will only contact you if we need more information.

What’s next?
Bugs and issues that have been successfully reproduced by QA will be categorized and prioritized—game-breaking bugs will receive the highest priority, while middle-of-the-road and cosmetic bugs are prioritized based on reproduction and the number of times reported.

4 Likes

Would you mind sharing your internet connection details? I’ve a theory that this issue is only being seen on high speed fibre type connection. So far of the 14 posters who have shared their connection details all of them are on high speed > 100mbps. The only poster who was not on high speed (40mbps) was NOT getting a CTD.

1 Like

I deleted my reply. It was just a rant about my experience with zendesk and has no place in the bug reporting part of the forum… :face_with_open_eyes_and_hand_over_mouth:

We have received a few tickets related to this issue on Zendesk. Thank you for those. What we have seen so far is that there are no common nominators between these tickets that would indicate clearly the cause of this issue. If you wish to report this issue via Zendesk (with the required files), we would appreciate it. The more data we have, the easier it is for us to diagnose this issue.

Asobo is investigating this issue and when we have more information about it, we will provide it to this topic.

If you wish to troubleshoot this issue yourself, you can do it by following the instructions below.

After you have seen 1 or more of these CTD’s, create MSinfo file.

HOW TO GENERATE A MSINFO

  1. Open a Run command box. To do so, press the Windows key and R key at the same time.
  • Alternatively, search “Run” in your Start menu’s search bar.
  1. In the Run window’s dialog box, type msinfo32 and click OK.
  2. When the System Information window opens, give it a moment to pull information from your system. You’ll know it’s done when you click through the menus on the left and see information for each of them.
  3. Keep “System Summary” highlighted
  4. Click File, then Export…
  • Do not choose File, then Save as. This will create a very large file that you may not want on your system, and our system has a file size limit that might reject it.
  1. Name your file something simple, like “mymsinfo”, and make sure it’s saved as a text (.txt) file.
  2. Save the exported file on your Desktop or your My Documents folder.
  • It can take a minute or two for the file to export and save.

After you have created this file, open it with notepad and scroll down until you get to [Windows Error Reporting].

Below this, you will find all application crashes that have been happening on your system. If you see the Sim crashing, but also something else crashing within the same time frame (±30 minutes), it is something that you should investigate and try to resolve.

Below is the list of crashes we have seen so far from the reports we have received on Zendesk:

  • faulting module combase.dll
  • exception code crash 0xc0000005
  • faulting module kernelbase.dll
  • faulting module couatl64_MSFS.exe (this is GSX and even if you start in safe mode, GSX will still connect with the sim via simconnect. It is recommended to uninstall this program completely from your PC and try to see if the issue is resolved.)

You can use your favorite search engine, for example, with keywords “faulting module combase.dll crashing” to find articles on how to troubleshoot and resolve the issue.

Below are some articles on the most common crashes we see and what troubleshooting steps you can try.
[SOLVED] | “ntdll.dll” crash issue | Quickly & Easily! - Driver Easy
How to Fix Ntdll.dll Errors in Windows [10, 8, 7, etc.] (lifewire.com)
Faulty Module Name Kernelbase.dll causing application crashes (thewindowsclub.com)
How to Fix the Error Code 0xc0000005 on Windows PC (makeuseof.com)
How to Fix an Error Code 0xc0000005 on Windows (helpdeskgeek.com)
How to fix Error 0xc0000005 on Windows 11/10 (thewindowsclub.com)
Combase.dll: How to Fix It if It’s Missing or Crashing (windowsreport.com)
How to fix combase.dll missing error in Windows 11 / 10 (thegeekpage.com)

4 Likes

My internet connection is 500mbps.

Thanks B787Pilot. So that’s now 15 out of 15 responses indicating a high speed connection. To me this is a common denominator but I’m guessing the zendesk has more data which disproves that as they state in the post above that they are not able to see any common denominator from the tickets so far.

I’ve pushed my theory to the risk of annoying fellow forum members (and maybe moderators!) so I’ll leave it be and hope for a speedy resolution whatever is the cause.

Has anyone tried rate-limiting the connection in MSFS itself (I believe you can assign a max bandwidth number - but I don’t have the sim open and I’ve never worried about it before so I could be wrong) to see if there’s a ‘magic number’ that makes this go away? That would be a good diagnostic step, I think. I will have a go myself if I get the time, but my sim is currently in construction mode :slight_smile:

Also, I’ll connect my VPN and do a speedtest, so I know what effective bandwidth is available, but this is a paid-for VPN so I imagine it’s pretty fast.

Edit: tried that with the same VPN and endpoint on my desktop PC and the results were:

Download: 932Mbps (non-VPN) vs 831Mpbs (VPN)
Upload: 865Mbps (non-VPN) vs 62Mbps (VPN)

That’s quite a difference in the upload speed. Could that be relevant? Upload, not download?

Excellent suggestion - I’d never noticed this either but there is a setting under DATA options/DATA BANDWIDTH USAGE/BANDWIDTH ->5-10-20-40-UNLIMITED mbps. I’ve set mine to 40 and removed the 100mbps cap I placed on my network adaptor connection. I’ll report back…

ETA: Since I placed the 100mbps cap on my adaptor I’ve only had 1 CTD in 3 days rather than the 3-5 per session.

ETA2: Doesnt appear to work, at least on the world map. Heres my usage after setting the value to 40mbps and moving around the world map. Clearly more than 40mbps!..

ETA3: Hahaha - loaded into the flight and a CTD! On the very first time since removing my adaptor cap :frowning: (and the 40mbps setting was still in place)

ETA4: network adaptor cap back at 100mbps and flying happily. I’m leaving this as is until fix found.

How to - 2 days ago :wink:
https://forums.flightsimulator.com/t/sim-crashes-when-zooming-in-at-the-worldmap/607606/115

1Gb connection. I had a few CTD in the past but right now, zooming (or choosing and airport/sid/star) results in a temporary freeze of about 10 secs. This happens with practically each session ATM.