Sim Freezes when Loading into Airports/Airfields SU5 and SU6

Hello. This isn’t a CTD as such, yet its equally as frustrating.
Support Request Number: 114773

All these issues have started happening after the Update 5 (Game Version 1.18.14.0)
Latest Windows 10 64Bit Professional 20H2 Build 19042.630
GeForce GTX 1080 8GB
i5 6600K
32GB RAM
Thrustmaster HOTAS Warthog
Logitech Autopilot Panel
Nothing installed in Community Folder. No add-ons just a fresh copy of MSFS2020. No World Updates either. No drivers for any of my hardware are installed.

I can load into the Sim fine. I can fly the training flights, and the Discovery Flights I can fly no problem at all.

Its as soon as I try and load a flight from the world map my problems arise. To start with it happened at certain airports, now it seems to be getting progressively worse. I will go to lets say White Waltham, Booker, Heathrow, Gatwick and more all over the globe. I chose a parking spot, or runway to take off from (no real world weather, no traffic, everything turned off) Choose a plane (it has happened with numerous planes, so its not plane specific) and I hit Fly Now - the sim will load to around 50% and just freeze. The music is still playing in the background. I have waited 30 minutes to see if it will load into a flight with no success. The only way to get back to desktop is to Ctrl - Alt - Delete to task manager and kill the sim. I have tried everything in Overkills video to troubleshoot, including uninstalling the sim, reformatting the hard drive, deleting all the left over folders, and it is still doing the same thing

Is there a folder I have missed when uninstalling that might be causing the problem? Is anyone else having this issue (Screenshots attached) As selfish as it may sound I’m hoping there are so it’s not just me.

I got no potential fixes for you. But I feel your pain!!

SU5 is buggy and unstable to astounding degree. I’ve had times where it seemed to be working great, much better fps than before, then I’ll have other times where I’ll get tons of CTDs, frozen sim, controllers going haywire, etc.

I think Asobo needs to do a three if not six month feature/world freeze and just make this software work. It’s just ludicrous at this point. Every update is some fixes and a lot of new problems.

And the chaos of broken, troublesome add ons after each update is getting infuriating. Get the add on API settled so it works consistently! Provide tools to the end user to see what add ons are causing problems or are using inordinate amount of CPU/GPU and hurting fps. And it sure would be amazing if they added the ability to load new add ons and completely unload add ons without having to restart the sim entirely, this would make debugging which add ons are problems much, much easier/faster. Detect improper add ons when they are loaded and report the issues to the user so they can choose to try to live with the issues, or remove the add on from the community folder. Add on are one of the greatest strengths and yet also one of the biggest problems in MSFS.

8 Likes

Yes, I had thé same problem as you described. Furthermore I noticed that the moment the progressbar freezes,there is no internet activity, probably due to a non responsive executable. Emptied community folder, with no luck.Started looking in Windows event viewer and Found a hint pointng to fsuipc. V 7.2 was installed. I uninstalled this version and installed thé latest V 7.2.4. No more freezes. Maybe that is a solution for you, if you also have fsuipc installed

1 Like

No Fsuipc installed. But most of my issues are CTD, not freezing.

I did have FSUIPC installed but I deleted it from my PC completely and haven’t reinstalled it. I have left the sim completely stock with no add ons at all so I could troubleshoot with a fresh copy of MSFS. I was convinced it was a 3rd party program that was causing a conflict. I was going to add them into the sim one by one until the issue arose. I didn’t for a second think it was the update causing it. I’m wondering if there is a folder I have missed for FSUIPC? It might be an idea to install a fresh updated copy of it, and hope if there were any folders left, it will overwrite them? Worth a try.

This is just one of the situations I have had. I tried loading into EGLM White Waltham in the UK (my home airfield) and the freeze occured. So I task manager out back to desktop, reload the sim, goto Sydney in Australia as its the other side of the world, and load into the airport fine. Fly around no issues. Go back to EGLM and the same issue, it freezes.

So I tried Gatwick as its 30 miles away from EGLM, and load in fine. So I fly to EGLM to see if it’ll crash. It doesn’t. I land at EGLM. Go back to the world map. Select EGLM and it loads straight in. No issues, so I think its fixed. I’m overchuffed. Come out of the sim, do a restart, back to EGLM and it freezes again. this is happening all over the globe. It’s almost impossible to troubleshoot as its all over the place.

I’m completely lost now as to what to do. And it doesn’t help I just spent £400 on the Thrustmaster Warthog, £120 on 2 button boxes, and £110 on the Premium Deluxe version.

I’m sure it will get fixed eventually, but right at this moment I am gutted as I have no timescale for a fix, and its out of my control. It’s something I can’t troubleshoot, as I have done everything I can think of.

3 Likes

What are your current LOD settings? If it’s anything over 100, try lowering them and then restart to try again

Well, I have fsuipc installed in a separate folder on another drive. I noticed that there is alsof a folder in the communityfolder generated upon install. Uninstalling removes thé latter comp!etely, however the uninstaller leaves a ini-file untouched in thé main folder. I manualy deleted this file before reinstalling a newerversion. Tried to Spawn today at Southend :laughing:

I was responding to the OP

I also have TM Hotas Warthog. And allthough I have not used fsuipc yet for Axis/Button assignments, It makes me wonder, 2 Common denominators. I do Hope you get this solved, because it is frustating not able to fly

My LOD is pretty conservative to be honest, I think its set at 80, but what I will do is put everything on Low or Off and see if I can load in consistently if at all. I wasn’t using FSUIPC for my Warthog, I was using it for FS Radio Panel Pro which is an App for your tablet which allows you to control your radio stack etc. Great little app, although it’s not much use at all atm lol. :laughing: :sob: So if that .ini file was in the main folder, it would have deleted when I uninstalled and formatted the ssd.

And thanks for the encouragement. I have a really nice home Sim (well I think so lol) which took me a while to get it to an acceptable level and I can’t use it unless I want to hunt for an airport I can actually fly out of, with lots of Alt Tabbing to desktop in between. And it’s pointless me putting my add ons back in, and reinstalling drivers, as I might have to do another complete reinstall.

Hi I’ve also experienced the same issue. For me the cause was a marketplace airport. LVFR KSAN (which is fantastic btw, I highly recommend anything LatinVFR). The game would go unresponsive on loading screen. I am completely puzzled because my friend who has the same airport and nearly the same setup has never experienced the issue. It also has allowed me to load in on the rare occasion but it seemed to me every time I removed the marketplace airport I was able to load in. Sorry I know this doesn’t help you much as you said you were completely vanilla. Wanted to share for anyone else reading, I’m having similar issues loading in and it is hard to pinpoint the exact cause.

Thank you for reporting this Stewart. At least I know I’m not the only one with this issue, and vise versa. You’re not alone. My sim was working perfectly before the Update 5. Not a single issue. Smooth as silk as well, with medium to high settings. Even though my system isn’t the most modern. So I am in no doubt it is something in update 5 that is affecting some of our PC’s which in turn is messing up our sim’s. My last resort is a full reinstall of the operating system. Luckily my PC is dedicated to MSFS2020. Its all I use it for, so there isn’t a lot to reinstall and back up. It’s just an absolute pain in the ■■■■ that I really should not have to do to get a working flight sim. But if it is something to do with the information Microsoft Store hold and back up, even a reinstall of Windows 10 isn’t going to solve the issue.

I still won’t say anything bad about Microsoft or Asobo despite what is going on. These things happen with the multitude of PC setups there are in the world. I just hope they don’t do what a lot of developers do and after a bit of basic troubleshooting and pre written fault finding sheets say, well we have tried everything you’re on your own. That would be devastating. Somehow though I just don’t see it.

I’m having the same issue, since the latest “hotfix” the game won’t load into the aircraft. I never had this issue after any previous updates.

3 Likes

So when you press “Fly Now” what happens? Does the sim start loading and then freeze?

Yes, the blue bar will get to the end, then just hang up.

1 Like

Okay fost mate, well you need to put in a ticket, so Asobo/Microsoft know it is an issue affecting a few of us. They are more likely to troubleshoot the issue if more of us express our upset at not being able to load a flight. :+1:

As an aside, this was happening to me before I installed the Hotfix. I was hoping the Hotfix would solve it.

Did the same after buying FSDreamteam’s LSZH through marketplace. Uninstalled it as part of the trouble shooting. It did not help. I agree with you that it is very hard to pinpoint what is going on

Wanted to give it a followup.
Today sunday and was looking forward to some hours VFR flying.
Guess what? Back to pre-update fsuipc era. Seems that this was not a long lasting solution
Freezes after pressing the Fly-button (Progressbar always get stuck half way and taskmanager showing a non responsive program)
What I cannot understand is that yesterday, after upgrading fsuipc, I managed to make a 3h VFR flight in Europe, shut down the PC , fired it up today and back to freezes, without me changing anything.
I am not going to reinstall the sim and/or the OS, because my guts tells me it is not on my side.
You did all this with zero results :grin:
If you find a solution , would appreciate it if you post it here

I have had the same problem since update 5, Was first identified when I tried to load Discovery London, screen freeze with program running but eventually locks up, but all other Discovery flights run great. . Tried loading Heathrow and Gatwick and same problem but Edinburgh loads and runs ok. Tried a number of UK airport and ok. Jump forward to last night and installed G1000 update then tried to load Edinburgh which CTD and have never had a CTD. Uninstalled G1000 update and Edinburgh loads and runs again. This got me thinking was this the aircraft I was using, the C172 so changed to the Savage Cub and now Heathrow and Gatwick load. Could the glass screen aircraft be the problem?

My assumption is that Asobo also updated photogrametry of World Update including US, UK, Japan when they updated SU5.
Mod sceneries which have the reference to the previous version (SU4) of photogramety will lose the reference because these US, Japan, UK photogramety have been updated to new ones during the SU5 installation.
I uninstalled all the mods which have the reference to photogramety sceneries for US, UK, Japan.
After uninstalling these mod sceneries, all loading problems have been disappeared.
Certain mod sceneries have no problems during their loadings, but they make the loading problems in other scenery. For example, KSAN airport scenery has no pleblem during its loading but it make other ploblem in Chicago area loading.
I will wait until all these third party sceneries are updated.

The scneries I uninstalled: (I found these mods make the loading problem on Chicago KMDW airport.)

Chicago Landmarks
KCGX Merrill C. Meigs field
KSAN San Diego International Airprot
Landmarks London City pack
Landmarks Paris City pack
Seattle Landmarks
Tokyo Landmarks Enhanced
Washington Landmarks (This scenery is not photogrametry but need to be updated.)
And others … related to US, UK, Japan photogrametry.

Edited : Aug. 2.
The rule is not only for World Update 1 to 5. Some other area have the similar loading problem.
The list above need to be checked again.
Some mod conflict with SU5 and this conflicts affect the next other airport loading
One clear thing is that deleting some mods can solve the loading problem. And Asobo need to solve this compatibility issue.

1 Like