Sim Update V ( Bug Megathread

I this a bug or am I doing something wrong? I get approach information from ATC for Chigago, and go to the flight computer to set runway 10L as destination to catch the glide slope, (Never done it by computer before, normally just use the heading bug to steer myself)

Anyway, as soon as I choose the runway my co-pilot files a new plan and the plane does a 360

The VFR map crashed after setting the runway as destination (frozen, can open and close but not manipulate, doesn’t move, doesn’t respond to any input nor resizing).
And in the second screenshot you can also see the air temperature is wrong and I had to fly 300ft higher to satisfy ATC.

Hmm, looking at it further, where is it sending me. Are those estimated arrival times? Where is ARTIST, where is GIBNS. My plane just keep flying, passing Rockford now. I hate automation lol.

Hopefully the ASOBO team is on it, and we’ll get a fix sooner than later. For me, my mouse is erratic and I can’t click menu buttons. The white dot is just, horrible. I would like to request a fix of the brightness, or please set the gamma back to SU4 settings. Great frame rates and really, it still looks amazing flying at low levels. I do enjoy it, and I know this is just a setback. The sim is evolving so, there’s bound to be a few bumps.

I5-9600kF, ASUS Z-390 MB,Geforce GTX1660, 16GB DDR4, 2TB SSD, Corsair H60 Water Cooler

Why should I? The person making the claim should spend the time to provide the source. I didn’t make the claim so I am not spending time looking for the information source. Sorry, neither a screenshot of max memory or Xbox specifications tells me NOTHING.

If the information source is not available and not posted, the claim should be removed immediately.

I had mine disappear seemingly in locations covered by LVFR’s Airport Regional Environment X Europe addon. Deleting this in Content Manager and rebooting brought the vehicles back. I could then reinstall the addon which worked.

It is really really sad that on final the PAPI lights are so out of focus that it’s very hard to even sometimes tell if they are white or red.


Purple water
Purple liveries for add on ones installed
Draw distance sucks
Pop ins everywhere on ultra graphics
Ultra / 200 slider graphics look like LOW graphics from pre SU5
TBM930 engines just stop working mid flight without pressing anything at all multiple times
Cant use ESC key to get out of options menu anymore
Game crashes 90% of the time when on new satellite imagery on world map
Freezes when unplugging controllers etc…
PS5 controller which i used to be able to easily use as showcase camera, no longer works as it never shows up as “wireless controller” anymore in controls… and is replaced by one that says “TrackIR” however i dont have a TrackIR installed or anything like that.

List is big for me. Frustrating, and im probably missing stuff.
Im shocked another fix hasnt been released already or any kind of “tweet” or message informing us that they are working to fix our issues.

I found a bug.

KLAX is showing as magenta colored on the mini moving map. Also magenta on the G1000/G3000 aircraft. It’s a towered airport lol.

Edit: I also have a bug where I’m at the correct altitude and ATC keeps telling me to climb. Even after I press B for correct altimeter setting.

-Graphics don’t stick (Settings do not stick since SU5 - Bugs & Issues / Install, Performance & Graphics - Microsoft Flight Simulator Forums)
-Toolbar doesn’t disappear until switching into different application tab
-Mouse cursor disappears after using keyboard in-sim
-Mouse cursor centers on top-left of screen after using keyboard or joystick in-sim
-LOD decreased massively (NOTE: all settings on ULTRA)

-Temperatures still inaccurate on LIVE weather (LIVE weather basically completely broken) which hugely affects aircraft performance.
-Managed altitude no longer works (A320neo)
-Even more pixelated clouds
-Fuel and payload no longer has the slider to control the overall weights of fuel and payload individually. Instead you now have to manually input the weights for each tank (fuel) and sectors of the aircraft (payload) FIXED: G1000 v0.4.0 caused a conflict for this. Delete this version and replace with the NXi. Bug has returned - unsure how
-UI no longer shows the keyboard inputs to “escape” for example. It will instead show something like “Joystick button 3”.
-Scenery pop-in
Will continue to add to this list as I remember and experience some more bugs. Apologies if I have duplicated any bugs already mentioned.
-The CUSTOMISATION tab no longer functions properly. Backspacing the registration that you have typed in previously clears the field, yet when you use any aircraft, the registration still appears on the aircraft. To properly clear the field, you now have to interact with the field with the mouse and then press F4 to clear it. No changes are saved on this tab.
-Cloud reflections extremely blurry
-Low GPU usage caused by live traffic


This looks cool. Check out the graphics. Anyone know where I can buy this? :rage: :-1:

this entry pattern is rather confusing :sweat_smile:

I tried to go for the other last minute ,but at least didn’t crash in the middle…I crashed on the other deciding to go for the other when it was probably already too late :joy:

1 Like

It’s a new bug, happens to me since SU5, it’s worse than the old ‘return to previous waypoint’ bug because once it happens ATC are involved so no fixing it. So IFR approaches are out.

Figures, just when I get into the ILS side of things. It still worked, with another loop…

Then ATC stopped talking to me when I directed the plane to Kansas and took off again. The new flightplan with ILS approach worked (without loops!) yet ATC was dead and the VFR map never recovered.

Dead VFR map and no options for ATC (manual tuning had no effect either)

1 Like

After crashing I pressed restart ,since there is no option to reload directly after you crash & even when “restarting” right after you crashed ,sometimes it restarts the game from crash position a few secs or sec before impact. Also had this with airbus reloading at sea level after crashing.A bit more proof to show that the save files do not compound all the data in reliable way at the point at which you saved your flight.Often after reloading ,you notice the flight is totally not in the same state at which you saved it.

Not sure if the voice switching is due to connection issues on my part,but I had these warnings pop up ;

& the voice completely changes indeed.First I thought it was a local accent at Seattle ,where the game failed to register my frequent flyer miles achievement. Maybe it has to do with what @SvenZ posted though ,that ATC is stopped/cut off for some reason
At first I was kind of excited hearing a different kind of voice,as I thought it was a first step towards implementing Use Azure to give ATC regional accents - #12 by N316TS

Further problems I have experienced (Series X):

  • A320 AP does not function correctly. Very slow climb above 20,000FT, unable to change speed and VS knob doesn’t work.
  • Unsure whether VRR is working correctly on TVs with 120Hz capability. Seems to be a lot of stuttering and pausing when both options are enabled through Xbox.
  • Rolling Cache may not be working correctly.
  • Objects do not load in quickly when changing camera, usually more-so in external view. Very noticeable ‘pop-in’ across aircraft, terrain and pilot avatars.
  • Xbox version does not have a LEGACY option for cockpit interaction, even when using mouse and keyboard.
  • Aircraft are usually too fast when landing, despite the correct procedures to land.
  • AI Trim is broken in Flight Assistant and does not work as intended.
  • Flight Assistant ‘recommended’ speeds are wrong for all aircraft.
  • ATC calls out incorrect altitudes even when not, asks you to expedite.
  • Rudder does not work on some float planes.
  • Performance improvements required. Using smart-camera drops the FPS by a large amount.
  • Keyboard commands do not always register, requiring several presses.
  • Toolbar line doesn’t hide.
  • Invite to Group (multiplayer) does not work, always says someone left the Group.

strange lines also dented into the river Thames near EGLC London City airport,east side

1 Like

Umm, I think the flight plan is missing a zero. This is going over 12,000 foot mountains.


That is hilarious! :+1: :rofl: :smiley:

Steam achievement related bug
Landings at new airports not counting
My count has been at 11 for over a week :sweat_smile: Im very sure I landed successfully at more than 11 airports since I started playing.

what @Roostermiester shows Sim Update V ( Bug Megathread - #528 by Roostermiester might explain a few things.
The ATC does not take the profile of an airplane into account ,giving instructions;

Here you can see that 10000ft is the max altitude for the Extra330LT, yet ATC instructs me to climb & maintain 16000ft. its a wonder I even got over 10000ft if its the so called max :sweat_smile: or maybe it wasnt above max altitude since the altitude is not correct,landed at -1800 or so. But the ATC instructing planes to go higher than the max is a thing.

might be more proof for this

In the following picture,you can see how IFR has a waypoint suggesting 7747ft at arrival, ATC asking me to descent to 3100ft,while altitude says i’m already at 1290ft …but visually still above the clouds

I’m at a loss of what to do in such situations,or as we say in dutch sometimes “didn’t know how to make arrows out of wood”
The altitude is wrong obviously,but it didn’t suggest me to press b to correct at all.

What is the Cruising Altitude in your flight plan? ATC uses the flight plan cruising altitude for climb and descent instructions. If the flight plan cruising altitude is 38,000 ft, you are telling ATC that your aircraft is capable of flying up to 38,000 ft even if that is a lot higher than the service ceiling.

I completed the flight,but after a bit of searching I found the Navlog again.

I don’t understand its only 2500ft …the mountains there are way higher… & the ATC told me to go way ,way higher too ,as you can see in the images above
Didn’t really set up flight in depth(now i know i can thx).Just selected direct GPS & off I was.Maybe GPS is not able to take mountain hight in calculation or so? no clue really what the issue might be.But obviously I went a lot higher than 2500ft