Sim will not start: Stuck on Checking for Updates

Since I have the MSFS (Aug 2020) this has never happened and I have never seen this screen.
They fixed the CTDs, it won’t start anymore !!!

If you want help, you need to provide more details. Also a better title will help others in finding your topic.

Not a problem on my side, MS servers are very slow, even for FORUM pages take minutes to exit, but my internet connection is stable at 40MBPS
Thanks

immagine

99% sure it’s one of your mods causing it. Rename your community folder to community_old, and try again.

If that fixes it you have the fun task ahead of you trying to find which ones of your mods was causing it.

Would also help if you named your topic to something more descriptive, and move it to bugs&issues.

Might try and start up your Xbox-program in your start/programs/xbox-thingo… the other day it said it couldn’t find my login and it took ages for it to go beyond that screen.

hope it helps.

Woof ~ Woof

Steiny

Still not much information you have provided. What is your platform, any addons used, Steam or store version?

I really appreciate your advices, but the problem is not on my side but only on the side of the MS servers which are absolutely slow.
Since yesterday I have changed nothing in the Community folder and rightnow I have also tried to empty it but I repeat, the problem is not on my side and I find it shameful that the servers that in recent days sent the SIM in CTD if the real weather was active now they don’t even allow the game to start.

immagine

Same problem here.
Stuck on checking updates, the forum is slow and some services are not available.

I had this happen a few times over the past year, basically just a reboot did the trick for me each time it happened.

Did you use the Google maps mod at any point in the past?
There was another post with a similar problem and it turned out they didn’t properly uninstall the mod which led their OS to refuse all connections to MS servers.

Come on now. You keep playing the blame game without answering even the questions of a Forum Moderator. Where’s your respect?
How can we help, what we really like to do, when you are already pointing to something that’s out of your influence? And also of the moderators. You’ll turn people away in this way.

You say that you didn’t change anything in your Commy folder. But maybe something sits there that’s wreaking havoc with this specific update? Have you even tried to rename it, log out of the store and xbox app, restart your machine, log back into both apps and try again?

And the forums being slow is as far as I know completely disconnected (being on completely different servers) from the sim-updates. But I might be mistaken in this.

Pretty please?…

MSFS worked until yesterday without any particular problems, today it cannot connect with the servers and I have changed nothing, my PC is dedicated only to MSFS and when I finish flying I turn it off until the next flight.

1 Like

Dude, take it easy

1 Like

Same here. I am trying every suggestion find with google. Only thing different from yesterday is the picture where it says it is syncing something. 0% — 100% then goes to checking for updates and remains there for ever.

I have had the same, being unable to update or stuck in the press any key loop. The above recipe always got me up and running.
I am not sure but it could have something to do with having two accounts one one pc. But that’s a somewhat wild guess that I plan to dig deeper into.

Just trying to help, that is.

Same for me. “checking for updates”. No changes in my setup today.

Have you tried to search the forums?

Sorry, maybe I wasn’t clear.
I flew with MSFS yesterday, after the flight I turned off the PC.
I turned it on today, WITHOUT CHANGING A BYTE and it doesn’t work.
What should I look for? It goes without saying that it cannot connect to Microsoft’s servers.
I live in Europe, it would be interesting to know if the other SIMMERS who have problems are also in Europe.
This FORUM is also very slow, I’ve never seen it so slow!

Are u Italian, right?
I also have the same problem tonight…screen remains in “searching updates” forever. I think is AN Italian or european problem…

1 Like

Yes Jordan, I’m italian too, it could only be a problem in our country.

1 Like