The settings are erased after SU7

Now when I press “Fly” at an airport I get beginners information about assistance setting and am told to change them if I don’t want to be informed. WHAT IS THIS? This was an effect of SU 4 or 5 as well. Grrr. I need my settings back and to remain from flight to flight and from restart to restart of the sim.


A reset of the assistance settings during the update. Can happen if the old settings section is compatibel with the new. Just set it again how you want it to be and continue flying.

1 Like

I have set it once since the update yesterday. Today when I started the sim and a new flight the settings were changed back to EASY… And those were not the only settings changed.(Or unchanged if you like.)


This woudl be expected, as the settings have significantly changed since the last version, and is a known occurance here, and in many other software. Annoying, but sometimes unavoidable…

I know many (non developers) here will say “why cant it just keep/migrate the existing settings?”.

As a developer I can assure you that we try hard to migrate configuration when we create new versions, but sometimes on certain applications with high levels of customisation and user modification (such as MSFS) it is sometimes not possible to do RELIABLY all the time, and when faced with the descision of either clearing existing settings, or tryign to migrate and face other stability issues, we woudl choose the former.

If you find that Assistance Settings are constantly being reset to Easy without you initiating it then please report your findings in this bug thread:

One simmer told us that (s)he had the user.cfg file set to read only. That’s why the settings did not persist.

1 Like

Happened to me too. Took my by surprise…LOL. I had forgotten all that I’d changed at the beginning. Was able to reset after a couple minutes of fiddling though.

Yes, I lost EVERYTHING. Including control profiles, HOBBS / Saved state data, logbook, everthing. It’s like day-one install.

Assistances go to full after exiting a flight as well, you need to change them for every flight. Another bug posted on it.


Same exact issue is happening to me. I didn’t mind resetting the options once after the update, but after booting up this morning, everything is set to easy/full training wheels and cluttered screen so now I need to change back to the settings I input yesterday again.

Where is the option to turn off HUD in the Chase Camera? It is gone and I do not want the ugly instruments in external view. This update has already ruined my day.

The hud is set to ON by default (outside view and cockpit views) - setting has been moved to Assistance - User experience

Create a new thread for this, don’t want to hijack the OP’s post

1 Like

where is this user.cfg file located? There is only a UserCfg.opt file in LocalCache…

Ignore that, the UserCfg.opt file has nothing to do with preferences, it solely relates to graphical properties.


You can ignore my advice. I mixed up the graphical settings with the controls and assistance settings. I found this for you. Hopefully it helps you a bit in the right direction.

And if you mean assistance options, here’s a bug report you can vote for.

And another

1 Like

This might be true but there is a lot of other stuff going on as well. For example when in VR and inside the plane, my foot controls are not operational and my active pause on my throttle stick is inoperative. When I exit the plane via camera view, all things in VR work. Also when you press escape and then go back into the game the Lean mixture is full lean and you have to enrich the fuel supply or crash!!

I can go on to say that my Beach Craft is no longer flyable. IF you bank to the left and then level the wings the plane continues to bank to the left by 2.5 degrees. Same think if you bank to the right then level the wings… 2.5 degrees to the right. This never happened in V 6 update.
I have at least 150 hrs on the Beach Craft and I know how it use to fly.

This version is almost not flyable along with the mouse issues… Can’t talk to ATC anymore as the mouse is not operative on the drop down menu… This software was not beta tested enough and really takes the fun out of the game… #pc
Gord. Rose.

Hello, after being through this unpleasant experience I figured out something: apparently there are different shortcuts to start the sim, with different behaviors. You should start always with the same shortcut. If you run SU7 once, use only this startup.
To launch every time the most recent edition (i.e. SU7 - GOTY), open the Xbox app (not the Console) look for MS Flight Simulator and scroll down to “compare editions” and press “Go to game” under the MSFS. Standard (or whatever) Game of The Year. Now go back on top and you’ll have GOTY here. Launch.
Or create a new shortcut using the latest installment.
good luck!

Same issue with me, i have done a complete delete and reinstall of the Sim, All my settings are completely gone every thing is set to default, tried doing some settings to the cam, apply and save, next time i start up all is gone and back to default!!! We all have a gametag connected to the Sim, should all our persanel settings not be saved on a server at Microsoft??? Seem that not every Simmer is having this issue, just the chosen few!!! Tried to contakt Zendesk, they repleyed going into the UserCfg.opt, and making a small change in the properties box, that did not change a thing!!! What is going on with the FS2020???
#pc Microsoft store version.

40 years of “software engineering”, not just programming and hoping that it all will work, and if it doesn’t, tell the non-programmers it can’t be helped and they should spend an hour or 2 reconfiguring their sim. There is NO reason why a HOTAS configuration, for example, can’t be migrated, aside from dev laziness. If you can’t migrate, you are not ready to release. MY customers NEVER had this complaint, and that is on mission critical software.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.