Thrustmaster hotas X calibration issue solved

I bought an Hotas X about 2 weeks before MSFS 2020 was released.
I was going to get a Yoke and pedal setup but couldn’t find any on sale for love nor money :slight_smile:

I installed the thrustmaster software that came with it and fired it up and all seemed ok. When FS 2020 was finally started for the first time it instantly recognised the Hotas X and I had no problems setting up the buttons to my liking.

What I did noticed however was that my planes where constantly turning to the Right. With further investigation I could see it was the X-Axis (aileron) spiking constantly about 25% of the full range to the right.

At first I though it was just a faulty joystick pot and was considering sending it back but then I thought, hang on a second, I didn’t see any calibration option, surely it needs calibrating.

Turns out the thrustmaster software has no calibration option, just a test option which shows you the various axes are moving. It also removes any calibration option from the standard Windows joystick panel.

I uninstalled the Thrustmaster software, restarted PC and fired up the windows joystick panel and found the calibration option had been restored.
Did the calibration as instructed and then for some reason had to repeat it, but since then the spiking X-Axis problem has disappeared.

So if anyone is having issues with their Thrustamster sticks, try removing the Thrustmaster software, it seems pretty useless anyway. And then calibrate from the windows Joystick panel. :+1:t2:

3 Likes

I get constant left-hand turns. :smiley:

Well if it’s a badly calibrated Thrustmaster try what I said.
If it’s the torque effect of the prop I can’t help you, you the need god to change physics :slight_smile:

1 Like

I don’t think it is P factor. The rudder input is very twitchy as well, speaking of torque effect… :smiley:

I’ve been building my own pedals to plug into the Thrustmaster throttle and had installed the software to see if there was a firmware update, I also noticed the normal windows calibration was gone with no replacement. The TM software looks nicer than the windows but I agree that it is useless without any option to do a calibration. It’s been deleted on my system as well.

Same mine is banking left no

You can change the sensitivity in the options - there should be a blue box over on the far left side near the top, just below the selcetion bar, that says “Sensitivity” on it …

Sensitivity was not the Issue I was talking about. I was talking about calibration and the fact that the Thrustmaster software removes the Windows joy.cpl calibration functionality and it’s own software does not include a calibration option.

1 Like

Could this sort out the rudder axis? I have problems with that, I press for the rudder to go left or right and it looks like the rudder is fighting the control

Well it’s a good idea to calibrate any analogue controls before use.

Just press the WIndows key and R key to get up the run dialog box and then type joy.cpl and click on ok

You will the see a list of your controllers image

Click on the one you want to calibrate and press properties, you wil then see this

image

Click on the settings tab at the top and you will get this
image

Click on calibrate and follow the instructions carefully to calibrate your joystick/controller.

See if that helps your rudder.

Also check that it’s not got other controllers or keys assigned to the rudder in the flight sim controls setup.

2 Likes

Yep, the S HOTAS (T1600 + TWCS) and Warthog HOTAS don’t need calibrating, so we don’t get that option -just the Test tab :¬)

I just assumed you’d already done that - is there not an option under Start->Thrustmaster-> Control Panel?

1 Like

I don’t know about the T1600 or the warthog, if I’m right in thinking they don’t have potentiometers so maybe they don’t need calibrating.
But the issue is the hotas X is potentiometer based, and does need calibrating, but the thrustmaster software that you are directed to download for the Hotas X only has the Test option not a setup/calibration option. It also removes the windows built in calibration option too. So you are left with no way of calibrating it unless you remove the thrustmaster software and reboot, then you get the built in WIndows one back. Which is what I’m suggesting people do if they want to calibrate their Hotas X.

1 Like

Make sure that your rudder axis isn’t bound to any other input.

WOW Thanks for posting this I was able to fix my its either all the way off or all the way on , rudder issue… now I dont have an excuse for not lining up the runway , thanks :slight_smile:

Oh good , glad it helped someone. :smiley:

Learnt many years ago to always check my calibration for potentiometer based controls, but in the excitement of getting MSFS up and running I forgot to check it.
When I did remember I suddenly realised there was no calibration option with the Thrustamster software installed. Stupid omission for a company known for Joysticks.
:thinking:

Found some more info, don’t know if it works for you …

caaront 21 Feb, 2018 @ 5:21am
"Joystick calibration is hidden in Windows 10, found it, here’s how.
I discovered that if you hold ctrl and shift down while you click on properties it reveals both tabs.
So I was finally able to calibrate my stick.
Hope this helps another W-10 user. "

I’m still pretty sure it’s Windows hiding it, not Thrustmaster due to this post from back in 2016 :¬)

1 Like

Might be useful info for some, but I saw that mentioned before I decided to uninstall the Thrustmaster software and it didn’t work for me.

1 Like

Have you reported the issue to Thrustmaster? It might help others if they know :¬)

1 Like

No I haven’t I’ll look into it.
To be honest the Thrustmaster software is not needed anyway the driver is automatically installed by windows 10. Their software just gives you a test page that proves all the axes are moving and the buttons are working.
Unfortunately it also removes the calibration option.

Not sure if anyone is still watching this thread but had a question as I have this issue as well. One thing I noticed is my HOTAS 4 only has the issue on my desktop PC and when I switch to my PS 4 OR Laptop it clears up. 2nd thing iv noticed is that my PS4 and Laptop have Gen2 USB ports and the ports on my Desktop are all Gen3 - 3.2. I installed a PCIe USB 2.0 expansion module in and started doing some testing and it seems to have cleared up on my Desktop for now.

My questions to anyone else having these issue are 1) do you remember if you were plugged into USB Gen2? 2) If not have you tried plugging into a Gen2 port? Iv ran into these compatibility issues back when 3.0 was first coming out and even tho the HOTAS4 is a newer device I have a feeling they used older gen parts for better reliability on PS4.XBox1

1 Like