VCRUNTIME140.dll Error

If you run a search through your registry, if in fact all other vcruntime instances have been removed, how many registry entries do you find. Simply deleting .dlls will create a ton of new registry errors. Your drivers, et al will be looking for the location of these missing DLLs based on the registry entries. Suggest running a registry cleaner following the removal of DLL packages and then a clean reinstall of your required drivers. Then a test MAY result in improvements.

1 Like

because there is one from MS-Store / Steam.

See also:

Lots of posts show us the issue with these error-code is more often not the version of the lib, instead hardware, driver or conflicting application…

Hello, here a user affected by the same error and crash

I have fixed the problem by following these steps in the following order:

  1. I have removed ALL mods from the "Community" folder.
  2. I have disabled any OC to the graphics card, in my specific case using AORUS ENGINE
  3. I have uninstalled from the control panel "Rivatuner Statistics Server" and "MSI AfterBurner".
  4. I have installed "Microsoft Visual C ++ Redistributable for Visual Studio 2015, 2017 and 2019 x64".
  5. I have restarted the computer, I have opened MFS2020 and it worked perfect for a long time.
  6. CPU


Well hello everyone. First and hopefully last time posting here.

I had this crash for a while now. Thought it was FSUIPC7 and did everything as posted, then read about MSI Afterburner causing the issue. Removed it as Uxio states above and it was gone. Still had some CTD with no faulty dll but that’s community stuff and my own fault.

Updated yesterday and it all came back as bad as ever. Before, I could go 2h30m until it CTD’d and now I couldn’t even get to the start menu. Tried everything posted above as well as:

Emptied community folder
Removed all third party programs, including FSUIPC7, Volanta, etc.
Uninstalled VC++ Runtime library
Reinstalled the 2015-2019 version of VC++ Runtime Library
Fixed registry
Ran System File Checker
Turned off DEP
Tried Hardware troubleshooter
(last 3 or 4 from how-to-fix-error-code-0xc0000005-in-windows/ by stellarinfo)

Always tried to start the sim in between steps. All of them with a clean reboot of the pc. Nothing worked. Crashed after 1-3 seconds in the main menu.

Didn’t want to give up and go into a fullr einstall as I couldn’t see how the whole install would just randomly screw up so I tried resetting the app (Windows Key, Settings (cogwheel), Apps, Search for MSFS, click, advanced options, reset).

After I rebooted as per usual, I got to the Checking for updates screen and it wanted me to do a full reinstall. Was about to loose hope and right when I did I browsed to the file directory where my FS was installed. App realised everything was there and proceeded to reinstall about 1.75GB of data.

After downloading and installing it, it took about a minute to start the loading process, with a not responding message in between (so don’t give up if it does happen to you), then it loaded. FR+BENELUX loading screen popped up, it finished, and voila, it’s done. Loaded onto the menu and working right as before. Didn’t fly yet but I’m certain it’ll be fine.

Hopefully there won’t be more issues. If there are, I’ll post again.

Man that was a rollercoaster lol


I was playing without issues from release day last August until around the Japan update when I lost interest in playing for a while. In February, after a few months of “hiatus”, I decided to check out what’s new, hoping to find inspiration. Sadly, what I found was a series of vcruntime140.dll crashes, which I never experienced earlier, between last August and October. Uninstalled, reinstalled, nothing helped. Tried most suggestions found here, still crashing, 100% of the time, often in the menu, sometimes during a flight. So I hibernated the buggy sucker again, only to check back now. Why now? Because I wiped my computer clean, formatted all drives, everything is up from scratch. What a great time to try again! But I quickly realized nothing changed, regarding the stability. The game crashes pretty much 100% of the time. Same error message.

I am hoping that one day someone will finally post the good news here that the solution is found to this issue. Until then, I am sending my flight sim back to hibernation.



the post from @Uxio1214219 summarize all points which are in our experiance the reason for these error ( for none VR usage ) and we summarized it some time in forum.

  • usage of mods :: rare that a mod cause the vcru…dll error
  • overclocking :: more general this point stand for hardware issue. Caused from hardware itself or the drivers ( mostly GPU , sometime chipset )
  • side effects of incompatible tools which running in parallel
  • sometime re-install of c++ libs are helpfull

Have you checked this points ?

Otherwise without more infos, the community can also give no more hints. But you know these already as we know from your former posts

I was able to play for 1 month and a half, with an OC of the RX 6800 XT @ 2700MHz and the Ryzen 5 3600 @ 4.3 are cooled by a Be Quiet Dark Rock Pro 3, with 0 CTD
Now even without OC I have CTDs

I was able to fly 15 hours, without having CTD, before having CTD again
With or without Microsoft Visual C ++ MSFS works, but it prevents other games or applications from working.

I only have Windows installed on the PC, with O applications, apart from the driver for the RX 6800 XT and MSFS.
So what would be the parallel application that would be incompatible, knowing that the RX 6800 XT @ 2700MHz has never caused CTD for more than a month

I can understand that you are trying to help people who have CTDs, and that is to your credit. But now, you have to come to understand, that there is a BIG difference, between us who are victims of these CTDs and you, it is that you cannot validate all these pseudo solutions that many people have shared for 8 months now.
You have to come to understand, that just because you will post the same messages 1000 times, with the same solutions that do not work, things will change.


MichalMMA seems to be unable to understand what I was already thoroughly explaining back in February. Incompatible tools? Rubbish! Re-install C++ libs? Rubbish. Overclocking issue? Rubbish.

The sim was running fine for me from the release day in August last year until about late January. Then, in February, I noticed it started crashing to the desktop, always on the same error message. I had my PC custom-built, overclocked, never an issue. Never an issue with C++ libs either. If it was an issue with overclocking, incompatible stuff or libs, then the issue should have been present from day one. But it was not the case. Therefore, it is something else, on the simulator’s side.


The VERY long list of non-exhaustive solutions that don’t work.



as often mentioned… for issues with VR we have this category:

nobody told that OC is bad in general in knowing hand ( I use e.g. kinf of OC like ‘sync all cores’ ).

Mentioned was: it is one of the possible reason and one which can cause the hardware issue.

we never recommend to de-install the C++ libs completely

What we know:

a lot of users report issue with this special graphicscard, or more exact the AMD drivers ( or tools which enable so called “Auto-Performance-Mode” which is nothing else as overclocking GPU.

we find out some kind of it ( fraps, former msi afterburer with older riva-server, … )… some others are mentioned within FAQ. As you can see I answered also not to one of your posts, so again: it is one possible reason we find out.

if you would read the former post of the user which I anserwerd, then you would know why I made the question. He still give no additonal informations as " I changed nothing, so it must be the game".

New we get these additional infos:

so… my question to kityatyi was valid:

Still no other informations about its system, nothing where we can start a open discussion. Still

: Crash to desktop without error message - #3480 by kityatyi

I am afraid, MichaMMA, you are somehow locked in an endless loop.

Once again, for the last time and then I no longer bother to explain the same to you over and over again.

Overclocking was present on release day. No issues. C++ libs were present on release day. No issues. Everything I currently have up and running was present on release day, yet I encountered no issues. To summarize, I have not changed anything in my system and the sim was running perfectly fine between release day and the end of 2020 when I took a break. Is it clear until this point? I did not have a single crash. There indeed were dozens of issues, such as bugs in the aircraft systems, scenery and so on but stability wise, the game was fine for me until the Japan update. After the Japan update, I stopped playing because I lost interest. When I came “back” by the end of January, I started getting the crashes. Once again, for you to understand, I still had the same system that ran the game with no issues from release day until the end of the year. Nothing was changed on my end. If my system was to blame, I should have encountered the crashes from the very beginning. But it’s not the case. What I found, however, is that when people have not a single clue, they start pointing fingers at stuff such as missing drivers, overclocking, missing libs and so on. But not during my 25+ years of hardcore flight swimming experience even once any of these were the underlying problem.

So, back on topic. My system never changed. What changed was THE SIM, the SOFTWARE. Updates were applied and thus it is legit to assume that the issues started to occur with one of these updates. Asobo probably introduced something, a bug or an incompatibility that plagues certain systems. It is clear that it is a sim issue, something that came from one of the updates and not something that suddenly appeared out of the nothingness for lots of us.


Thanks for this, I won’t hesitate for a brief second! :grinning:

1 Like

and I simple asked: have you tried the things which working fine for @Uxio1214219

Your answer is still that you not want to try something and that’s okay for me and we can ignore your issues.

No, I have not altered my overclocking because my PC was custom built by Overclockers in the UK and never since I first turned it on - again, NEVER - ever casued an issue with ANY games, including games way more demanding. So, no, I have not messed with my overclock because it was delievered to me from the shop like that.

I have indeed removed and reinstalled each and all C++ libs, individually and altogether. Did not help.

I disabled Azure, dd not help. But again, I did not need to disable Azure on launch day, why would that be the issue anyway? Does not make sense. Nevertheless, I tried and did not help.

Tried different Nvidia drivers too. No solutioon.

I do not have Afterburner installed so that should not be the cause. Overall, I never fiddle with my system, I left it pretty much as the shop sent it to me. I did not overclock anything any further, did not increase GPU voltages etc. My system is in the state Overclockers US (shop) delievered it to me. And it is awesome, robust and powerful. Yet, MSFS started crashing at some point after the Japan update. The Japan update was still fine, I played a lot, but then I got bored so I stopped playing and haven’t touched the sim until late January. So, whatever updates came out after the Japan update and before the end of January are probably the keepers of the “secret”.

Finally, last week I formatted all my drives. Reinstalled Windows 10. I did it just for pure, regular maintenance, but I though I also check if it helps with the game. So I also installed MSFS onto the fresh system. Drivers all up to date. The game crashes, 100% of the time.

Something has been introduced in one of the updates.


thanks… so we can have a discussion and I can add comments which may be helpfull or you just already knew.

What we can do here is only try to find possible settings… we never can find issues in code, this must do the developers and therefore the questions like “have you tried” also in case there is seemingly nothing changed on your system side ( if we ignore e.g. these million windows updates ).

The lib version we have mainly no longer in main-focus, in special because MS-Store users get this from ‘internal’ , only Steam users seems to use the system wide lib. But re-install is still on the list to be sure. I also shown here a possible way how to find out which one is used.

The old Azure issues ( ATC voice ) seems no longer cause issues… may be some traffice stuff. Of course nobody can be sure, but e.g. the latest server issue related to this shown us, that the app seems stable related to this: it not crashed.

I read no bad things about the latest 466.11 nvidia driver and it runs fine in my case. And if you not use HAGS, then I assume no issue from this side… but may be depends on GPU model… there are huge diffs in the graphic-cards models related to issues ( 10xx, 20xx, 30xx ). More strange is the last windows update, but I assume we can ignore this here.

We have some experiance with pre-configured systems which are running fine in normal usage or for ‘usual games’ , but crashing with MSFS. Often the power-supply was the “bad boy” and game runs fine after users replaced it. One, or two times the GPU was defect and we had also cases with defect memory sticks. But that we can exclude all these, we asking for disabling the overclocking and run a test-case without any overclocking ( store the current setting in BIOS into a profile , then you can restore ). The worst experiance we have with overclocking of graphics-cards.

But sometime the app crash also because of the connected usb devices. But normaly with another error message as the “VCRunt…dll”. Similar to errors which some users get if they use memory overclocking with xmp profiles and others…

In special if you mention that “The game crashes, 100% of the time.” and if we assume you get not allways the VCRUNTIME140.dll Error (then it is a other story) , my first guess would be in meanwhile the windows virtual memory (pagefile). That this comes of top started more with a 1.11, or 1.12… They get normaly a 8000003 or a 0000005. Affected are mostly the users with 16GIG RAM, but also owner of 32GIG RAM run into these issue. Therefore the question about your system specs…

May be you can recheck the windows event log whether you still get the VCRUNTIME140.dll Error.

We here, the community, find of course not allways a solution. But we can try it and thats why we asking. But users have to allow it, or say directly that they just want to report without any discussion ( in this case is ZenDesk much more important ). If we would do same as Gsx31 (or also bit you) and we say allways “the game is the bug” , we had never can find all these settings with which help a lot of users can play MSFS without any kind of problems. Sometime of course we not find the issue.

1 Like

Finally, some useful communication.

I indeed have only 16 GB RAM. However, I refuse to take it out of the box that it is the reason why the game crashes because it did not crash at all from release day until the end of 2020. So it cannot be the fact alone that I am having 16 GB of RAM, unless - and I repeat UNLESS - something VERY demanding was added with one of the updates. On the other hand, there are numerous reports from users with 32 even 64 GB of RAM about the exact same kinds of crashes.

Graphics card. I have the Nvidia MSI 1070 - an oldie but goldie -, which I find reliable. It never gave me a headache. It is getting outdated but so far I have not felt that it’s bottlenecking my gaming. I could run all games I wanted to play without issues. DCS, a number of P3D versions, racing games, FPS games and so on. While there are way more powerful cards out there, it cannot be the cause of the crashes since MSFS did perform very well on my system from release day until the end of last year. If my card was not up to the task, I should have experienced the issues right from the start.

USB ports failing is a good point, I actually thought of that. But the question is, why all of us here suddenly have faulty USB ports? Nonetheless, it is something worth looking into, for sure.

I also take into consideration a possible failing graphics card or perhaps a dying PSU. But again, it is unlikely that suddenly, all of us have this issue. Because it seems obvious we are experiencing the same problem: VCRUNTIME140.DLL being it.

All of my crashes - 100% of them - are VCRUNTIME140.DLL crashes and they occur early on in the game. Therefore it is logical to assume it’s the devs that introduced something that takes a toll on some systems while leaving others untouched. Or alternatively - but again, unlikely - failing hardware. But in that case, other, clear signs should also appear and that is why I don’t think it’s the actual cause. Nonetheless, I will get my PC checked by experts soon, to rule out a possible hardware failure.

1 Like

As I said, since 1.11/12 the reports about memory issues ( mean the not-enough memory ) comes more and more on top. Additional with the fact that for some users the window auto-increasment of pagefile works not as expected ( e.g. because low on disc space related to the increasment rules ) the users must do only one simple setting related to the windows virtual memory. Switch from “System Managed” to a value like “min: 8Gig max:20GIG (better30GIG)”… and ensure there is enough free space on disc. Thats it. And yes, also users with 32GIG are affected and / or have other kind of issues.
May be you can try it as first ( it helped realy so many users ).
The summary about all the analysis before e.g.: Finally.....Solved CTD issues... for those of us with < 32 GB ram
( e.g. Settings → Info → Extended SystemSettings → Tab Extended → Performance → Extended → Virtual Memory → manual 8192 / 30000 )

The 1070 is good one… not high-perf, but good old ages, as you mention.

ähmm,… not all… the most users which have an issue with this, can not start the game. There are issues, not sure whether they are fixed, if usb devices go into sleep-mode , e.g. often the wireless devices.

1 Like

Same issue…lol
Faulting application name: FlightSimulator.exe, version:,time stamp: 0x60783c14
Faulting module name: VCRUNTIME140.dll, version:14.28.29231.0,time stamp: 0x5f4c66c9
Exception code: 0xc0000005
Fault offset:0x0000000000001fc2
Faulting process id: 0x26b4
Faulting application start time: 0x01d735c1fa784480
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.15.8.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\Program Files\WindowsApps\Microsoft.VCLibs.140.00.UWPDesktop_14.0.29231.0_x64__8wekyb3d8bbwe\VCRUNTIME140.dll
Report Id:1abe2732-6959-42be-b84f-c9a4377fb7dc
Faulting package full name: Microsoft.FlightSimulator_1.15.8.0_x64__8wekyb3d8bbwe

Had these again. Tried everything once more and it didn’t fix them. Couldn’t even be in the air for more than 5 to 10 minutes.

Followed this right here and now testing. LFMN-LIPZ it would crash at around 5-12 thousand feet and so far so good have been cruising for half an hour almost. Will report back but leaving this here so people can try.

Uninstall the latest windows update:

1 Like

Recently, I have noticed more and more posts in this thread describing CTDs while flying 3rd party aircraft. I can only assume that the number of people experiencing CTDs that are actually flying the default aircraft with default liveries and default sceneries is getting slim.

Please remember that this thread is dedicated to…

“VCRUNTIME140.dll Error” using ONLY the default sim.

Before posting here, PLEASE remove ALL mods and add-on content to determine if the failure is with the base sim and NOT related to any add-on.

To discuss issues with add-ons and 3rd party software you should always start at the vendors website.

1 Like