VCRUNTIME140.dll Error

Do you have any update to your trouble shooting?

At this point I’m kind of wonder what the heck is going on with this. It seems everything and everyone is all over the place.

I know that there are three of us in a large group of online streamers that almost always have CTDs and all three of us have AMD CPUs and GPUs of various varieties. I’m the only one out of the three that when I get the CTD it also sets off my AMD bug report/debugger, so I fill that out and send it in…

I’m trying a few things today to see what happens: I’ve manually set my GPU to work in “high performance mode” from the setting menu in windows, I’ve uninstalled all the oculus software including tray tool, and I uninstalled and re-installed the redist files in proper order, did the deep uninstall with DDU on my GPU, no over clocking or anything like that, created a pagefile.

I’m trying to think back to when all this started and it seems like there was a lot going on, I got a Rift S, there was the UK world update, I added a second monitor, etc. etc. It really is rediculous though because is the point of a piece of software to work is that it works on machines that at least meet a minimum requirement?

I would say this is an AMD issue but I see plenty of people with Intel and Nvidia hardware going through the same thing.

Here’s what I’m trying today:

  1. Removed All Oculus software including tray tool
  2. Set MSFS App to run in High Performance Mode
  3. Going to change my data limit from unlimited to 40
    • Updated router and rebooted* alright done yesterday and had a CTD in a flight of 3
  4. Will try to disable onboard integrated graphics port on my MoBo if it’s available

Again, it’s like throwing a bunch of stuff at a wall and seeing what sticks. The setting the AMD radeon software to “manual” without changing anything has me intrigued though.

And just so I’m clear on my System:
CPU AMD Ryzen 3600
MoBo: Bazooka B350
Ram: 32 gb
MSFS installed on 1 tb SSD
PSU: EVGA 220-G4-0750-X1 Super Nova 750 80 Plus Gold 750w

And just a side note, I find it extremely obsurd that apparently if any one thing that changes to your computer can cause just MSFS to be the problem. The PCs are always in a constant state of change whether by updating, how someone is using, what programs are running that you may not even know about, etc. etc. BUT only MSFS is affected. The fact that people are on here saying that it’s YOUR pc or hardware is really beyond belief because if that was the case than people would have all kinds of issues with other software titles and they aren’t. It’s always a consistant “only get this with MSFS” and the response is “well it’s you or your PC not MSFS because of X” but we all easily meet or better the minimum requirements.

I don’t know, I’m exhausted trying to figure out what is going on and we shouldn’t have to go through this and I have spent a TON of money on and for this software and this is the best responses from support I get. I just can’t wait until this software hits the Xbox market and we’ll see how fast things really spiral out of control when those servers get nailed by a bunch of new players and how many times you think console players will download 100+gb. :frowning:

2 Likes

The only thing that worked for me was to disable Xbox Game Bar. Ever since, I haven’t had a single CTD, at least not during a flight. I’ll still get a driver timeout followed by vcruntime140.dll only if I’m in the main menu AND I’m switching back and forth between Windows and MSFS. Otherwise it’s fine (ie. no CTD when I’m switching during a flight).

This seems like a very rare scenario and I doubt my workaround will help others though.

1 Like

I understood that there was no point in complaining with our CTDs because we were responsible in their eyes for our problems.
This is not where we will find a solution.

On the other hand, maybe they would do a little more effort to solve these CTDs, if ALL possible future buyers of MSFS knew about all these problems, and they refused to buy it.

So I just had a successful 4 hour flight on the North Europe server with about 60+ other players in a group. FPS was solid and only minor stutter BUT no VCRUNTIME error.

Is the problem solved? Uh, no. But I’ve had multiple CTDs during streaming and this was the first time in a long time everything went right.

Here’s what I did if you want to try to reproduce it (warning: I did about 4 different things all of which I can’t point to it being anyone one thing so your mileage may vary AND who knows I may end up getting a CTD later and I was just lucky this time):

  1. Uninstalled and reinstalled latest redist files (for the 4th time). I did this last night before bed and then said forget it.
  2. Using windows graphic settings added I set my RX 5700 XT to run high performance mode(instructions on that are up in the post somewhere)
  3. Switched my data setting in game from Bandwidth unlimited to 40 MBits
  4. I did not have an onboard graphics card to disable so did NOT do that as it wasn’t in my BIOS as an option
  5. Updated and restarted my Netgear Router/Firmware (done yesterday but I had a CTD during multiplayer flying yesterday so I don’t know if that helps much or not but it’s a variable nonetheless).

I’m doing more stress testing tomorrow in a large group I guess we’ll see how it goes and if any of this stuff actually stuck to the wall. Still find it silly to go through all of this but it is what it is. Luckily even if the sim runs for a short period of time it looks and plays so amazingly that I don’t usually stay mad at it. :slight_smile:

Yeah well that was too good to be true apparently, because I had 2 more CTDs within 2 hours. The first immediately after takeoff (could be VAT-Spy related although not 100% sure if the app was the root cause or happened to crash alongside MSFS) and then another one on the next 2-hour flight, a couple of minutes before landing. Very frustrating. I just tried to turn a knob (tips overlay is disabled) and boom.

vcruntime140.dll rules.

1 Like

note: be carefully with that… it may have an effect of the next update-download-speed

1 Like

Well, none of that worked. This morning flying in a group had the vcruntime140 + a .NET this time around. I’m officially given up. I’ve tried everything on forums, from the help desk, etc. etc. and nothing works. I’ve had community folder empty, etc. etc.

Faulting application name: FlightSimulator.exe, version: 1.14.6.0, time stamp: 0x60420b1c
Faulting module name: VCRUNTIME140.dll, version: 14.28.29334.0, time stamp: 0x5fa9a822
Exception code: 0xc0000005
Fault offset: 0x00000000000014b4
Faulting process id: 0x3770
Faulting application start time: 0x01d727587346942f
Faulting application path: F:\Steam SSD\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Faulting module path: C:\WINDOWS\SYSTEM32\VCRUNTIME140.dll
Report Id: 47ca9633-2137-4de9-8ef5-947a7bdbc5dd
Faulting package full name:
Faulting package-relative application ID:

Application: FlightSimulator.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: exception code c0000005, exception address 00007FFE2A4514B4

And yet we’re getting the online equivalent of a big stereotypical French shrug in response.

1 Like

I have started getting this error repeatedly, just adding it to the list, hopefully Asobo will look into it if enough people complain.

Log Name: Application
Source: Application Error
Date: 03/04/2021 21:20:49
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: John-Desktop
Description:
Faulting application name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x60420f33
Faulting module name: VCRUNTIME140.dll, version: 14.28.29231.0, time stamp: 0x5f4c66c9
Exception code: 0xc0000005
Fault offset: 0x00000000000012de
Faulting process ID: 0xa2c
Faulting application start time: 0x01d728c3a24ecfa9
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.14.6.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\Program Files\WindowsApps\Microsoft.VCLibs.140.00.UWPDesktop_14.0.29231.0_x64__8wekyb3d8bbwe\VCRUNTIME140.dll
Report ID: 724af031-8642-419f-9d5a-ac52f5a545d3
Faulting package full name: Microsoft.FlightSimulator_1.14.6.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App
Event Xml:



1000
0
2
100
0
0x80000000000000

60097


Application
xxxx-Desktop



FlightSimulator.exe
0.0.0.0
60420f33
VCRUNTIME140.dll
14.28.29231.0
5f4c66c9
c0000005
00000000000012de
a2c
01d728c3a24ecfa9
C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.14.6.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
C:\Program Files\WindowsApps\Microsoft.VCLibs.140.00.UWPDesktop_14.0.29231.0_x64__8wekyb3d8bbwe\VCRUNTIME140.dll
724af031-8642-419f-9d5a-ac52f5a545d3
Microsoft.FlightSimulator_1.14.6.0_x64__8wekyb3d8bbwe
App

seems like the thread is dead, but still having this issue despite trying EVERYTHING in this thread. Are there ANY solutions out there?

No solutions, Only wait for Asobo to fix it… I’ve tried everything even changing Mobo & CPU still the same its the sim, Has to be

Yes wait for a frog flight to pass in the sky.

I do not claim to have found THE solution, but I prefer to rely on myself, than on Asobo, to find a solution.

1 Like

Which C++ did you uninstall? Cheers

As I said HERE, EVERYTHING
CTD caused by vcruntime140.dll and Microsoft Visual C ++ (1)
Now there are some that are used for applications, which might not work anymore. So far, I have only had OmniPage Ultimate showing me an error message , but I haven’t taken care of it yet.

Ok Cheers will have a look :+1:

=>

what exactly you already tried from mentioned hints ?
( HAGS, drivers, overclocking , confliction applications , … )

I can see nowhere that you give more informations as sentence like " nothing works ". A ‘discussion’ is more as this :slight_smile:

What we know is, that you re-installed c++ lib and made a sfc scan. Anything else ?

What are your system specs ?.. Nvidia or AMD GPU ?.. etc…

i have the same issue sicne today. never happens before this update

Today after update WU4 I presume, which may be a special case as there’s lots of WASM-related stuff that I believe cause CTDs with the vcruntime error.

Hey everyone!

Upon ivestigating the vcruntime140.dll errors it turns out that MSFS will actually run fine without any VC redistributable installed.

OBS won’t. So as opposed to the advice in the actual How-To section at flightsimulator dot zendesk dot com Crashing-CTDs-issues I have downloaded the VC redistributable which is linked at the OBS website and have removed all other VC redistributables from my machine for the moment.

Turns out that there is a notable stability increase. Crashes since change: 0 (!)

Here’s what OBS recommend for a VC redistributable:
search with your fav search engine for: OBS Studio requires some additional files (Visual C++ 2019 Redistributables) that

*had to replace links with search instructions
*holding my thumbs that it actually continues to work

Nope. Keeps happening.