Bad warp effect with Radeon RX 6700XT

Hi, I’ve recently upgraded my Gigabyte Nvidia 1080 to an AMD Radeon RX 6700XT Challenger Pro 12Gb and was hoping this would enhance my MSFS VR experience, I my have been wrong! I am suffering from major warp issues - basically looks like there is a bowl of clear jelly between my eyes and the VR headset screens, even with very little head movement there are wobbles in my direct and peripheral vision). I didn’t get any warping like this with my Nvidia 1080 (and it wasn’t even the Ti version!).

I have tried multiple configurations using various tools but the warping just won’t go away. I’ve tried turnng ASW off with the Oculus debug tool, tried the same with the Oculus Tray Tool and tried various hardware configurations suggested on these forums but it just will not go away. I noticed there are some Vsync options in the 6700XT Radeon software settings but again nothing seems to work. I’ve tried completely lowering the display settings for the headset and MSFS graphics settings but the warping is like a bad smell :frowning:

My setup:

Windows 10
Oculus Quest 2
Ryzen 5 3600
32Gb RAM
ASRock 6700XT Challenger Pro

Has anyone overcome this issue? Is this an AMD 6000 range issue? I’ve seen a few people complain about the warping but couldn’t see any solutions.

I uninstalled all Nvidia drivers with Display Driver Uninstaller (DDU). I haven’t tried a complete windows reinstall, the thought of downloading MSFS for the third time sends shivers down my spine.

I’m getting desperate now and thinking of selling the card and revering back to my 5 year old 1080 for now. I’ll try tweaking for one more evening but get the feeling this isn’t going to go away.

Thank for the help!

If you use OpenXR, disable the retroprojection.
It does that with my 6800 XT MBE.

Don´t use the newest driver 21.6.x . I have the same experience with my 6900XT. Try 21.5.2 and it should be ok.

Thanks guys!

@Navas117260 Great shout! Warp effect has disappeared now, thanks very much, saved me the hassle of listing it on ebay!

Noticed 21.7.x has been released today, anyone brave enough to test it???!

That driver is Worse than 21.5.2 in vr. Try the 21.2.3 drive only installed through device Manger.

I stopped getting flightsim CTD in event viewer using this method.

Still get the wobble as all AMD drivers display.

6900xt here.

Thanks @Corei7rocks, yup the CTD’s had me a few times so interested in the 21.2.3 driver but couldn’t find it in the “Previous drivers” link, what do you mean “through device Manager”, sry, I feel I should know what this means!

Thx!

Google with a quick search https://www.amd.com/en/support/kb/release-notes/rn-rad-win-21-2-3

Extract the driver. When you get to where it wants to install after it extracts to a folder just canel after extracted.

Uninstall your previous driver and reboot. Open device manager when your back to the desktop, go to display the choose then properties of Microsoft generic driver then update driver tab and browse to where the driver was extracted to which is usually C/AMD/ driver version…and choose the the folder 21.2.3 and it will install.

Best of luck.

I tried it, still has the motion reprojection artifacts, so please avoid. I rolled back to 21.5.2.

21.5.2 has been worse for me. It is always freezing and more stutters that than 21.2.3

Thanks for the tips, I tried your method of installing v21.2.3 but unfortunately this version caters for 6800xt & 6900xt but not my 6700xt grrrrr. Now I’ve overcome the wobble effect I’m now being hit by the CTD issues. I’ll take a look at v21.2.2 perhaps!

Any luck fixing your problem? I have exactly the same issue, and we basically have the same PC specs, except my 6700 XT is a Sapphire Pulse.

Yes kind of, I’m using an earlier version of the driver (version 21.5.2) as suggested by Navas earlier in the thread. Relatively happy with the performance now, I was close to sending it back but thankfully this version sorted out my warping issue. I’ve also played about with Oculus Tray Tool, had mixed results but think this increased my frame rate marginally. Annoyingly I have had a couple of CTDs (crash to desktop) but after a few hours without any CTDs this weekend I’m going to stick with this card for now until the 3080s are a more reasonable price!

The downgrade seems to have made things better. I still get a bit of the warping/smearing effect but it is not as noticeable as it was before.

I’ve tried using the Oculus Tray Tool but many times it actually appeared to make it worse. I think I might not be activating it properly.

Do you know how many fps you’re getting? Using the developer tools, the frame rate seems to be at a stable 35-36 fps.

Also do you have any particular settings that improve your VR experience? I basically use the settings found here with some modifications:

The Quest 2 itself is set at 72hz with resolution at 1.0x, and Oculus Tray Tool settings which I got from a YouTube video are:

Super Sampling 1.6
ASW 18hz
FOV 0.7 0.8
Bitrate 500