KADW - Andrews - CTD Analysis by Community contributions

the error seems to occurs with file grammar.pggmod, related to Blackshark (propably the grammar to transform building footprints to 3d buildings

How did you determine that grammar.pggmod was causing the issue ?
Did that file change in SU6 ?

Could the pre-SU6 file be substituted as a temporary fix.

(Wonder who still has backups ? :roll_eyes: )

The current current one 10/19/2021 is exactly the same size as the one from 7/27/2021, and Bcompare says they are IDENTICAL

it was the last file loaded before CTD if i believe in crash report

i will try again the CTD with procmon running to monitor activity

its a joke or pun

no fly zone database is a database with no fly zones in it

I do not think the issue is with the “grammar.pggmod”

Not that one should – but -
I tried replacing both the “bf” folders in Official with version from back prior to SU6 (modding their versions so they did not update), and it made no difference.
All worked as expected, until entering the "CTD Zone)

I self admittedly don’t know how this works.

But based on what I’m reading, what if we created a new airport scenery with a helipad on top, not just exclusionary scenery.

Then make it smaller and smaller until we isolate the CTD.

… assuming of course the CTD is due to something in scenery to begin with…

Asobo already produced the Top Gun DLC and loaded it into the sim, but because of the delay of the Top Gun movie, they stored it off-site of Andrews AFB. Of course, to prevent spoilers and leaks, Asobo created a Bermuda Circle in that area to prevent people from coming too close.

I’m not sure what the confusion in this thread is.

Neither do I - its all a learning curve for me … but its more enjoyable than firing up the sim, only to end up with a CTD, in the area you choose to fly in.

To me, MSFS needs to be a SIMULATOR, and the only GAME part, is the game of hunting down the Bugs, rather than waiting an indefinite time for Asobo to fix them.

“God helps those that help themselves”

Last moment before CTD. it doesn’t help…

but the sim is loading vector data in 032 folder, the one for this area.

CTD seems to be gone.

go to folder
Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\Packages\Official\OneStore\fs-base-cgl\CGL\032

and remove file bldo010.cgl and bldn010.cgl (perhaps just one of them but i didn’t try.
(i have rename them bldo010._cgl and bldn010._cgl to not delete)
some vector data (i think buildings) will be missing but it is better than nothing

i just load the flight above the area when i had CTD, i didn’t fly

edit : removing only “bldo010.cgl” is enough to fix the CTD (best is to rename it like “bldo010.cglbak” and back it to original name prior to any sim update)

7 Likes

.cgl is either DEM data or Satellite images.

cgl is vegetation, coastline, dem sat, building footprint (autogen) road, river, lake etc…

1 Like

How about the registry key not found ?
HKLM\software\microsoft\windows\currentVersion\appx\PackageSidRefMicrosoftFlight…

maybe should be PackageSidRef\MicrosoftFlight…

I have a PackageSidRef but no PackageSidRefMicrosoftFLight…
or a MicrosoftFlight… folder under PackageSidRef

no, registry is not the problem, it is in these 2 files.did you try with just one of them instead of both ?

I tried replacing both with files from an earlier version… did not work CTD.

Now I am trying, as you did, just removing them

If that works, I will see if can add one of them back in, without it crashing

@Nirgal2776 You are AMAZING !!! with those 2 files removed, I can fly all over that CTD zone !!

Now to see which one is causing the issue … Great stuff !!

Just removing the

bldo010.cgl

stops the CTD is the area for me,

I did rebuild the layout.json ( do not know how really necessary that is )

SUCCESS … great job all, especially @Nirgal2776 - but it was a great team effort :+1:

Note: Replacing that bldo010.cgl with the file from a few months ago, did not seem to cure the CTDs, but , for the time being, until Asobo does a proper fix, removing that one file would seem to allow flying back into that popular area.

8 Likes

Can you see any abnormalies now in this area? Missing buildings and stuff?