Crazy monitor flickering then crash to Desktop when switching to VR (Reverb G2 WMR)

I have been using the Reverb G2 for about 2 weeks now and after getting the settings right (with the help of several posts here in the forums) I got everything running quite smooth.

For no apparent reason, since yesterday MFS starting acting completely crazy when switching to VR, but only when in a loaded flight (in the main menu VR works perfectly fine). As soon as either a flight loads when already in VR mode or I switch to VR mode during a flight, my VR view goes black and then switches back to the WMR room, while my monitor view starts flickering like crazy (while still showing the VR view). A few seconds later MFS crashes to the desktop, unless I exit VR mode.

This started happening after 2 weeks of working perfectly. I made no changes.
After trying everything changing settings, both MFS, Steam, and Windows, I decided to reinstall MFS and Steam. No change

I then reinstalled my graphics drivers, tried a different driver, tried rolling back Windows Updates. No Change

I then reset my entire PC and reinstalled Windows. I did a clean install of Steam and MFS without any other programs or mods running on my newly installed system. On the first try I was able to jump into VR in a loaded flight, look around for a few seconds, and the MFS crashed to desktop. Afterwards, the issue was just as before.

I could not find anything on the web about anyone experiencing similar behavior and have no idea what the cause of the problem might be. As the VR mode works fine in WMR and even in the MFS menu, I have no clue what could be causing such behavior only when in a loaded flight. As a full system reset / reinstall did not work, my only guess is that it is some kind of hardware issue - maybe a power problem. But VR works perfectly fine when not in a loaded flight, so this doesn’t make any sense either.

Also, when not using VR, MFS acts perfectly normal.

If anyone is experiencing a similar issue I would be grateful for some help, otherwise my next move would be to get the Reverb G2 HMD replaced.

My specs:

i7 10700K
GTX 3080 FE
32 GB RAM (2x 16GB DDR4-3600)
Win10 with MFS Steam Version (using WMR directly - not SteamVR) (I have tried with SteamVR with same results)
Corsair SF750 80 PLUS Platinum PSU

Appreciate any help with this!
I will try to upload a video of the issue shortly.

I just noticed that when I load a training flight, or activity, VR works fine with no issues!
As soon as I load a regular, custom flight, MFS crashes.
I am starting to think that this must be some kind of bug since the new Sim Update (although it was working fine after the update at first). I will probably need to open a bug ticket.

[UPDATE]: I have opened a Zendesk Ticket explaining the issue. Seems to be a bug since the latest update. Well done Asobo. I hope there will be Hotfix soon! No VR for me in the meantime :frowning:

This is happening to me as well. Can confirm that the menu and training flight worked fine, but when switching to custom flight (while in VR), the display appears to try and switch back and forth from the WMR home and the cockpit. The audio for WMR home keeps playing and restarting.

This is a new computer system with RTX 3070, Ryzen 7 5800x, 32 GB RAM. All drivers are the latest versions. Its been a few weeks since I tried VR on my old system where it worked fine. VR Headset is Samsung Odyssey.

1 Like

Thanks for the post, I am glad I am not the only one experiencing this issue. Its exactly as you say. It seems the display is switching back and forth very quickly between WMR home and the cockpit until it just crashes. I keep hearing audio from the cockpit though. I tend to force quit MFS if it doesn’t crash as otherwise the flickering gets so bad that my monitor already continued flickering even after exiting MFS.

Can you confirm if this has happened to you only since the latest Sim Update or also before?
Were you able to somehow resolve the issue? I just created a Zendesk ticket detailing the issue and hope to get a reply from the support team.

I haven’t tried VR recently, its been a few weeks, so I can’t confirm when it started. I only know that I had issues starting yesterday when I first attempted VR with my new system. It was working fine on my old system (GTX 1060, i5 6600) when I last tried. I have not been able to resolve the issue.

In that case it’s most probably a severe bug introduced with the most recent Sim Update 3. I hope they get this resolved really quick with a hotfix as otherwise VR is completely unusable.

I am also having the same issue since the last update. I have the HTC Vive Cosmos Elite and can confirm that the menus seem fine, well, stuttering like normal, but working. As soon as it goes to VR the headset just displays the grid area while the monitor displays the two lens VR view flickering like mad. After about 20 seconds the game just crashes to desktop. It did work once, in a bush trip in the cessna 172, but with any custom flight, just crashes. Tried some std edition aircraft models and bought ones like the T45 Goshawk, also tried std airfields instead of upgraded ones… all the same… no VR working except menus.

For reference:
I9 9900K
Nvidia RTX 2080Ti
128GB Ram
Vive Cosmos Elite
Windows 10 Pro (up to date)
Latest Nvidia Drivers

1 Like

Same here!

GTX3080 with G2 reverb

1 Like

SOOOOO glad to see this post, thanks for reporting to Asobo and letting us in on the bug.
Back to 2D ultra wide!
Nick

1 Like

Hello guys, at me exactly the same problems. VR not working anymore after last Sim update what I installed yesterday. Before all works fine with my reverb G2, no desaster and crashes. Hoping they fix this soon and that they read our problems…:pray:

1 Like

Make sure to upvote this thread… not sure if it helps but better than nothing l. I included a link to this thread in my Zendesk Ticket.

thank you for this information. I am newbie here on forum. I was looking for a solve for my problem on google and found this forum. I try to write asobo directly…they making a great job, but the last update :see_no_evil:…never change a running system :woozy_face:

1 Like

Probably a good idea if everyone experiencing the issue creates a Zendesk ticket so that it is seen and gets fixed quickly.
https://flightsimulator.zendesk.com/

1 Like

I just found this thread. I am not at my PC until Tuesday. Can anyone try this as a workaround to see if it works?

1 Like

This workaround works for me.

1 Like

Did not work for me.

Me to, I thought it was just me!!! HP G2

It’s not your headset that is the problem my brother is having the same issues (since updating to the latest build the VR works perfectly in WMR home and X-plane ,so i know it is not hardware related
His goes into VR in the sim then just keeps cycling in and out of VR.so i am guessing it is the update that is causing issues

I have the same issue. No solution yet.

I have a WMR Samsung Odyssey headset that has been crashing after the update. I tried the workaround suggested above and turned off my VFR Map and ATC windows which were open when the sim begain, one of which was on a second screen and got the VR to work at least for awhile. As I was flying the pattern the image sometimes paused and restarted, then crashed to the desktop. But at least I got into the sim. I also tried one of the landing flights and that seems to work well with no problems. Before closing the VRF and ATC windowsI it kept starting into VR & then keeps jumping back & forth to the Windows Mixed Reality Portal for about 15 seconds, then crashes FS2020 to the desktop.