CTD when connected to internet - Delete cloud data - this fixed it for me

I finally got to fly MSFS again the other night, after nearly 4 months of not even getting to the main menu.

To all those who say “it has to be something wrong with your computer”, trust me, I’ve tried on three different computers. The only thing they had in common was my MS Store/XBOX login. This led me to think and conclude with “it has to be something with cloud data or something related to my account”.

If I disconnected from internet, I could get to the main menu and I could fly, but I couldn’t download my purchases, couldn’t fly with my friends/online traffic, and the graphics were pretty bad. No immersion what so ever, which is totally unacceptable.

During this time I’ve been reading that you can make another account and add it to your family in XBOX. I did. It worked. I could fly. But I couldn’t download my purchases which was ‘stuck’ on my main account. So I felt cheated. “Really? Am I going to buy it all over again?”

I finally got through with support on Zendesk after a few emails back and forth with the usual “do this, then that, it should work now” whereas I sadly had to report back “nope”, and try to get them on to my thought “it has to be the cloud data, how do I delete it but keep my purchases?”

TLDR this is what they wrote

To fix this issue, you need to delete your cloud save on your PC.

This will delete your Microsoft Flight Simulator save data.

Please do the following:

  1. Open the Microsoft Store.
  2. Click on the Three Dots menu and then click Settings.
  3. Make sure your Offline Permissions is set to ON
  4. Start Microsoft Flight Simulator, once you’re on the main menu, quit the game
    (they told me in a second email to skip this step, because, obviously, I couldn’t get to the main menu)
  5. Disconnect your PC from the internet
  6. Quit Microsoft Flight Simulator
  7. Copy and paste your LocalCache and LocalState folders on your Desktop (for example), located by default here:C:\Users\your_username\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache
  8. Then head to your Windows 10 SettingsStorageApps & gamesMicrosoft Flight SimulatorAdvanced Options -->Select the Reset button.
  9. Once done, move the saved folders from your Desktop to C:\Users\your_username\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\
  10. Launch Microsoft Flight Simulator
  11. Follow the onboarding and launch a flight
  12. Reconnect your PC to the internet
  13. Connect back to the internet.
  14. On connected in-game, quit Microsoft Flight Simulator
  15. Launch Microsoft Flight Simulator again
  • If you are prompted to pick a save, you need to pick “LOCAL” for this time only. Moving forward, you will want to pick “Cloud”

When I followed this procedure, move the two mentioned folders and Reset MSFS, it actually uninstalled - the folder for MSFS was completely gone.

So I reinstalled MSFS and… it just works. Finally.
I don’t know if this is a unique case that it worked after these things, so I am sharing this, hoping more of you will get your cloud data wiped and can get on with flying again after such a long time!

Thanks for posting this useful information.


thanks for good summary / step advice.

We have often cloud data under suspection to cause trouble and in some posts is the removal for MS-Store users mentioned, but this is a good summary of the steps. In special because these removal is for MS-Store users not as easy as for Steam users, it might be a good point for official FAQ.

PS.: I can not give you a heart because its the Issue category. But see this post as it :slight_smile:


@OlaHaldorSV I hope you don’t mind that I took this information and created a post in the #student-pilots:advanced-pilot-help-guides repeating this information (and giving you full credit).

I also suggested in that guide that any further discussion should continue here in this thread.

Many thanks again!


So I have the exact same issue. however the step involving 3. Make sure your Offline Permissions is set to ON causes an error, similar to the error in settings of user profile in xbox for pc app, that in effect states I have to wait until november 24, 2021 as I have reached my limit of 3 “changes” in a 365 day period… i guess I’ve waited 2 months i can do another 2 weeks… but i find this restriction to be problematic for multiple reasons. It will be interesting to see what happens on the 24th.

I’m sorry but this is really confusing:

  • " (they told me in a second email to skip this step, because, obviously, I couldn’t get to the main menu)" - Step 4 is actually 2 steps, starting and quitting FS (what’s that good for?) and are you supposed to skip the entire step #4?

I ask because step #6 is “Quit Microsoft Flight Simulator”, which shouldn’t be running at that point if you skipped step #4 completely, and also if you skipped the first part of step #4. What’s the point there, to disconnect from the internet while FS is running?

Very important window.

5 Disable wifi or lan card via device manager

6 Click switch offline

press ESC > main menu > quit to desktop

Thank you TenPatrol! OK. so we make sure the computer is offline, then we make sure FS is switched offline too.

However, I still miss some explanation what we’re actually doing there and why, IOW what the mechanism behind these steps is and from what source they come*, whether or not you lose your hours/achievements/logbook/whatnot, how to verify the procedure was performed successfully etc.

It would certainly be appropriate if Asobo would provide this information officially, because, you know, it’s bad enough that people have to jump through hoops like this and everything should be done to make sure that this A) works and B) doesn’t make things worse.

*Strike that, apparently this came from Zendesk but was already garbled or got garbled on the way, it apparently missed a step (thank you again) that might be vital and that all looks like overall pretty poor communication, that’s why I’m getting a bit obnoxious here.

@CaptainNuts2000 If you get it to work successfully and the steps need better clarification then it would be helpful, based on your experience, if you could report back what a better set of instructions might be.


agreed, i still am unable to reset my cloud profile and the game will auto close when i try to launch. if i sign in with my sons profile it will work fine, just without upgrades and add ons. so i need to figure how to delete my cloud profile that is corrupted.

Is there anyone who had success with this? Zendesk sent me the same instruction and I tried, but it doesn’t work.
At step 10 I don’t manage to start MSFS when offline (although I have the offline permissions set up). The game tells me: "Due to an unexpected error Your game license could not be Authenticated. To access the online services, make sure to sign into the Microsoft store and to Microsoft Flight Simulator with the Xbox live account that was used to purchase Microsoft Flight Simulator. ".
I can then press OK, but nothing happens.
If I reconnect the internet for a couple of seconds and then directly disconnect again, it continues to load and ask the standards settings at first launch (graphics, world streaming, etc.).
Then, while still offline, I can launch a flight, no problem.
As soon as I connect to the internet, it crashes again.
Then, when I launch MSFS again, it asks me which savegame to load, but it still crashes anyway.
It’s unbelievable how messed up this is.

Be patient and wait 5-10 min.

1 Like

You are right. This worked in the sense that flight simulator launches.

Unfortunately once I reach step 13 and the flight simulator reconnects, the game crashed again.
It’s unbelievable.
With a different XBox account on the same computer it works, so I know it is related to the profile…

I’m in the exact same boat with what sounds like the exact same issue. No fix as of yet, and honestly, no sign that anyone is even looking at the issue. I would gladly work with someone over chat or screen share and voice from Asobo/Microsoft to help them figure out the core issue.

Hey everyone,

I’ve been experiencing the same issue. The only difference is that I can’t load a flight, the bar loads to around 70% and then stays stuck. The task manager says “not responding”.

3 days ago, it was working fine…
I tried everything I found on the internet :

  • Safe mode
  • Verifying local files
  • Clean uninstall and reinstall
  • No community folder
  • Switching microsoft accounts
  • Deleting local cache
  • Disabling traffic
  • Uninstalling and re-installing Navigraph data
  • Google Map mode
  • Offline mode
  • Nvidia Drivers
  • DX11/DX12
  • Pre-release


I don’t understand how a game can be that bugged and that we have so little information or solutions…

Anyway I’m open to any tips from you guys, if you experienced the same issues.

Happy holidays,

I tried this because my controls profiles were all messed up no matter what I did. It solved my issued but it also (temporarily) solved two other big issues. When you hold right mouse button to look around the cockpit inputs would freeze and yoke would not move. This one dates to SU5. Other issue was that the middle mouse click resets zoom in the cockpit and that was issue because middle mouse button was used to toggle free-look mode that didn’t work because of the issue with “right click freezer controls”.

After completing the procedure I was thrilled to find out that those issues have also been resolved, but only for like half an hour. I believe I changed my joystick sensitivity curve and made a new profile for the said joystick and afterwards both issued were back. Maybe it was something totally unrelated and out of my control, but it DID work for a short while.

If someone could test if they get the same results and maybe see what causes the right click freeze and middle click reset I would be very grateful

This is excellent (and well written!) step-by-step information to solve a problem that is quite vexing. @OlaHaldorSV - Thanks for the time and effort, and sharing with all of us.

I will add my own $0.02 here: twice (perhaps three times?) in anticipation of a major Sim Update I have Reset MSFS from the Windows Settings menu. (My software was purchased from the MS Store, not on Steam.) When you Reset it prompts the download of all new data, installing the software from scratch. In every case CTD events became quite rare, perhaps once in every hundred flights.

I do not know if the Reset method works in a similar way as the method outlined by the OP, but I do know that it helped when I was having CTD events (or controls behaving badly.)

On Steam version, I get a CTD after the ‘Checking for Updates’ screen, however, this only occurs when I’m connected to the internet. If I disconnect from wifi network or play steam offline mode, the CTD doesn’t occur and I play just fine.

I receive this error message after the CTD in Event Viewer:

Faulting application name: FlightSimulator.exe, version:, time stamp: 0x00000000
Faulting module name: ucrtbase.dll, version: 10.0.19041.789, time stamp: 0x2bd748bf
Exception code: 0xc0000409
Fault offset: 0x000000000007286e
Faulting process id: 0x1310
Faulting application start time: 0x01d7f947e3c73e07
Faulting application path: C:\Program Files (x86)\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Faulting module path: C:\Windows\System32\ucrtbase.dll
Report Id: 01e4f579-c74a-4f06-9c32-cec2f1be975c
Faulting package full name:
Faulting package-relative application ID:

I asked a friend about this and he said that it was because my Visual C+ + Redistribution library was crashing. I have no idea what to do with this information.

Help would be appreciated, thanks.

I’m so annoyed and frustrated over this I can’t even describe it.
Tried OlaHaldorSV’s checklist, but I got stuck at point 7, as there is no “Microsoft.Flightsimulator…” folder in my User\AppData\Packages-folder. Nor do I find the “Storage → Apps & games” thing at number 8.

I did however mange to somehow log off my xbox account after starting the game without network connection. Under my username in the top right corner in the main menu, I chose sign out, and put the cable back in my computer. Clicked the black pop-up window that showed up a couple of times, and it turned out to be a xbox login/log off windows.
But when I tried to log back in again, I’m somehow both logged in and offline at the same time.
It’s my username in the top right corner, but my status is greyed out and says “offline”. I can’t switch to online.
PLEASE update this post people if someone figures out a fix :slight_smile:

MSFS ms store or steam version?

Click Start → righ-click microsoft flight simulator → more → app settings

Turn on multiplayer :wink: