[UNDER INVESTIGATION] No streaming data working, photogrammetry and bing maps just stopped working

I was playing the game this morning just fine with full photogrammetry and bing maps.

Then a few hours later I came back to play and I have no online data at all now.

I’ve got all the online functionality turned on, i’ve tried rebooting, logging out of xbox and reconnecting, clearing the rolling cache, turning off and on online functionality but nothing is helping i’m still just stuck without realistic ground maps.

What’s really weird though is some areas are loading in with realistic maps but most of the globe is just the generic maps

I’ve tried so many things to try and rectify it, I’ve not seen anyone else mention this issue today but I can’t see why it would randomly just stop working for me for no reason. I’ve not updated anything on my computer today or installed anything new either.

Both XBox Live Services and Playfab (MS Azure underlying infrastructure for some XBox Services) show Green. I recommend opening a Zendesk ticket. Hope it works out for you!

https://support.xbox.com/en-US/xbox-live-status

https://status.playfab.com/

2 Likes

I have the same problem

5 Likes

Same issue here.

3 Likes

Same issue here

3 Likes

if I turn off online functionality it loads in using default scenery put if I switch to online it doesn’t work

1 Like

Same issue here, Started this morning Photogrammetry Bing maps is not loading and leave pink artifacts on the ground in certain places. At first I though it was some plants but now I see a whole bunch of people with the same issue. Hope Asobo is fixing this. This killed my mood to fly today. hunting it down to something on there end.

2 Likes

Anyone else encountering some weird random sim issues today? I was using the sim for most of today with no issues and then a couple of hours ago a few odd things started happening out of nowhere.
First thing I did was remove everything from my community folder so it is now empty:

Bing maps data is no longer working - All Data options are turned on in settings and internet speeds are working as normal. The maps on the World Map screen are all blurry too. I checked manual cache and all maps are blurry there too. It’s acting like I have Photogrammetry off but i don’t. I tried signing out of Xbox live and back in, no change

The Drone camera speed - It no longer changes. I put it up to 100 and it’s still the same speed. I put it to 0, in which it shouldn’t move at all, but still moves at the same speed.

Both of these issues above started at the same time. No new addons were added or any other changes made prior to the issue. Here are some pics of the issue:


3 Likes

Seen a couple of similar posts today. Sounds like server side issues.

Re the drone camera, that issue arose after SU5. To fix it, as a workaround, set the drone speed to something less than 100% and then change it to 100%. Might take a couple of tries at this before the higher speed “takes”

3 Likes

There have been a number of posts over the last couple weeks from people having this issue (see ‘Getting no satellite data anywhere’ for example, a bit further down in this forum).

I had the problem for about 5 days last week, then ok this week until yesterday, seems ok again this morning. I’ve tried all the suggested fixes on the forum and in the standard reply I got when I opened a support ticket which made no difference. My internet connection has been working fine at the time for streaming, other gaming, downloading and so on. The problem just sorts itself without any intervention from me.

It seems people having the issue are spread around geographically too so not necessarily a localised network problem. My guess is it is with the Asobo / MS servers like you suggest.

I’m wondering if it is a capacity issue, maybe since the XBox launch with a lot more users online at the same time.

6 Likes

yes, possibly. There is a related (I think) issue captured here that seems to be some kind of crossover between a world update conflict and streaming:

yeah even the maps app in windows is not working for me (its fixed now a couple minutes later lol)
in games still messed up

1 Like


every setting under “data” is on. World updates are installed, all is up to date. Xbox has good internet connection.

It worked fine some hours ago, suddenly the scenery is kind of offline.
Only changes were with language settings and offline cache increase.

any ideas?

1 Like

Maybe it is related to this issue:

3 Likes

Not sure if it’s related, but I’d also check your server connection speed. It won’t matter how good your broadband is if the FS2020 server you are connected to has a slow ping.

I am also currently having issues with seeing photogrammetry in the locations I have tested so far, Las Vegas, Los Angeles and Paris.

I tried deleting and building a clean rolling cache.

I cycled all on-line services off and on again. Still not getting any photogrammetry.

7 Likes

I’ve not had this problem today, but have in the past. I solved it by logging out of the Xbox app and then logging back in.
Hope this helps.

3 Likes

@TangledBinkie44 I just tried that and it rectified the issue. Many thanks!

Interesting issue to experience. First time I have come across it.

3 Likes

Just to add another voice to this- I am also having the issue. I thought prior to coming here that it may be related to the Volanta update which just came out today- do any of you guys use that? If not then at least that can be eliminated as a probable cause.

Happy to help, glad you are all sorted now.

1 Like