SimConnect stutter

UPDATE: A fix will come with the next patch. https://www.flightsimulator.com/august-27th-2020-development-update/


UPDATE: The original goal of this thread is accomplished. The developer SpringTrout3797 confirmed that they are working on a solution and promised a patch as soon as possible: direct link to the post.

Many thanks Asobo for fixing this bug and providing us with this great and promising flight simulator!

I will continue to update this post with any news that come up, so it can remain your central information hub for this issue.


I am creating this thread to raise awareness how important SimConnect is. Please reply with „+1“ or the specific limitation you face with SimConnect.

I am aware that there is already an open ticket. I am just worried that this might be perceived as a concern of a minority and not prioritized high enough.

The SimConnect stutter is the most important bug for me currently. It prevents me to make use of:

  • Spad.Next
  • FSUIPC
  • VATSIM
  • Plan-G
  • FSEconomy

And there are many more 3rd party apps that tremendously increase the joy of using the flight simulator, most of them tried really hard to be compatible on day 1.

EDIT:
Please also consider opening a ticket on Zendesk (how to report)! The more awareness we have, the better. This thread is only a supplement to real bug reports.

I am listing now all the apps that you mentioned here for your reference and to demonstrate the impact:

Preventing the following use cases:

  • Brunner force feedback yokes
  • Home cockpits (incl. Logitech/Saitek panels)
  • Mobifight
  • Motion rigs
  • Project Magenta
  • Simionic G1000, PFD&MFD
  • Simshaker
  • Virtual airline tracking

Similar threads:

105 Likes

+1

But posts must be at least 10 characters.

1 Like

Same problem here.
Using Ivao, FSA, Little Navmap

This is a pretty big issue as it affects so many other aspects.

1 Like

Same problem here and a lot of add-on are concerned.

For me, it’s also the most critical bug, since I only fly online on IVAO.

1 Like

+1

FSUIPC
FSEconomy
Plan-G

Same problem. It is necesary to resolve the problem, that appears on this release.

It’d be very nice if it didn’t stutter

Huge problem for me +1

Pete Dowson has released a beta version os FSUIPC that does not use Sim Connect.

Hi!

Link please ? On his forum hi states that simconnect is embedded in the FSUIPC executable… not that it is not using simconnect ??

Freddy

The issue is with the sim not Fsuipc

In beta and alpha versions, Little Navmap worked fine
and now it does not connect

+1 for me,
FSUIPC
FSEconomy
Plan-G

http://www.fsuipc.com/download/FSUIPC7.zip

without SimConnect

1 Like

+1 it broke my Spad. Next allowing me to control all my Saitek panels that I got very use to operate my flight with since Alpha.
Also I am using Simconnect with ForeFlight or I guess no more. Is it possible to just revert back to the part of the final beta that has a lot of stable features including Simconnect?

+1 here, need to fix this ASAP!

+1.

Me no like stuttering. Stuttering bad. Stuttering must go away. Awaaaay.

+1 I’m just using FSEconomy.