[BUG LOGGED] Unable to leave group, flight options greyed out - Xbox

Hi All,

I joined a group last night and I’ve tried to setup a flight today but I’m unable to change the weather or anything. I’ve got no option to leave the group and I’ve restarted my xbox, signed out and back in and yet it still puts me in a group.

How do I leave the group, I can’t find any option to do so :frowning:

I’ve spoken to my friend who created the group and he’s not even in the group he created. On the icon at the top he’s is showing as just a single player whereas mine shows as both the single and group icon.

This is really frustrating as I can’t set any options under flight conditions

I have the same issue after being in a group mp. There is another thread about exact this issue here: Cant change weather

Go there an vote it. Hopfully this will be fixed ASAP!!!

Thanks, I couldn’t see that anything had been posted about it.

Really frustrating bug to be honest

I haven’t had this error (yet?!)

Under options >general>data…

It might be worth turning off multiplayer-saving-turning on multiplayer-saving and seeing if that works.

If it doesn’t, try the same thing but this time for online, cycle it off and save and then turn it on and save and see if that does anything helpful.

This doesn’t change anything. This is what I tryed already more than once with no luck. The game still thinks we are in a group and doesn’t allow use to change weather and time. Also the Pause button in the toolbar isn’t anymroe there. We can’t use the pause function at the moment as of this ugly bug.

1 Like

Hi Tamalien,

Like MonkeyCH tried that, saved it, reloaded game etc and still thinks I’m in a group.

I’ve tried everything, but what I will also add, I’ve also got this same issue now on my pc installation that it think’s I’m in a group.

Why is there no option to either leave a group or it automatically leaves the group when you close the game. I’ve never seen such a weird implementation of playing multiplayer.

1 Like

I am currently out of ideas!

Thanks for reporting back that it didn’t work. It was a good idea to try changing the options>general>data> online settings to OFF, saving and then closing MSFS. Restart MSFS and then turn it back on.
If I get any more suggestions I will post them here.

I do recommend (if you haven’t already) filing a ticket with Zendesk, saying it is affecting your account on both xbox and pc.

I’ve already raised a zendesk ticket so it can be looked into.

I’ve even deleted my cloud save and that didn’t fix it. It’s very strange that it thinks I’m still in a group.

Only your cloud save or also teh local save? Did you again start from nothing? I didn’t delete my save yet as I’m afarid to start from tthe beginning.

Deleted local and cloud save and that didn’t fix it.

I don’t think it started from nothing

Ok thanks, then I don’t need to do the same.

I believe there are still some other issues with this bug, as also some options cant be changed at all. I tryed to disable the air traffic in the options and selected “Off” there. Than I save it. After reopening the options I changed to value “Off” is reversed back do “Live Trafic”.

This game is now not anymore correct playable as of this bug!

Maybe yall should pin my post, since I put almost all the different troubleshooting techs I did.

Yeah it’s a game breaking bug, yes you can fly but if you’ve been in a group and this happens then it’s pretty much useless

1 Like

:smiley: We have fixed this issue here by the following simple steps:

1 .The friend in which group you were (or eventually anyone else) must just start a new group and invite you.
2. If you are in the new group, select the “Leave Group” command on the Group icon menu.

After I did leave the group, everything seems to work again as it should. So in the future, until this is fixed, the group leader should not leave the group, until all invited members have left it. This way it seems to work fine. We just played together this evening and followed this rule and everything is still fine.

I hope this will work for you guys also. Good luck.

5 Likes

Hi MonkeyCH,

Nice one, I’ll get him to create a party and follow the steps you’ve mentioned.

Hello!
Im having the same issue. Im living in Japan and I was playing with a friend in Europe. Then, the game now always connect by itself to European servers and I can’t set Time and Weather anymore. To fix that, I Need to recreate a group game with him and left the group… It need to be fix.

Thanks

1 Like

I had a friend re-invite me to a Group as suggested in point 1. I click the accept button but when I do a “you left the group” message appears but I’m in a Group and able to fly with my friend. However, when I click the Leave Group icon it does nothing I assume because it thinks I left the Group when I clicked accept??

I’m trying this on the Xbox Series X version.

This message is “normal”. This “you have left the group” comes here too. How did you accept the Invite? It seems, that the XB Invite doesn’t correct work, but if you accpet it ingame under the notification Icon, it works and after that you must be able to leave the group by clicking the ghroup icon and select than the leave group menu item.

Good to know that the message is normal. I initially accept the invite in game by clicking the Accept button but also accept it via the Xbox notification. I’ll try again later just accepting the in game invite.