Approach flyback bug - Not fixed as stated in SU5

Please upvote and link any threads related to the issue of loading an approach in a GPS equipped aircraft it n will fly back to the last waypoint flown and lockout any further editing of the flightplan.

Original thread here:

Hopefully we can get this fixed.

From the first day with this problem and they still do not fix it.

PLEASE vote and help fix this. It makes selecting new approaches and go arounds a real misery!

Had same issue with other flight-sim games, and we need to get this fixed!

Does anyone know if this has been reported on Zendesk as well?

I have reported it. The more that do the more visible it becomes and the priority goes up.

Looks like the latest update doesn’t include a fix. Hopefully it will be in the next update.

More votes are needed for visibility. Almost there i think.

I don’t understand the voting system. Things are not fixed if it is not highly voted? In other words, we can have a damaged engine but people vote more that the water is fixed and then the engine will not be fixed?


No it doesn’t have to be voted on to get fixed it just increases visibility of an issue and may lead them to giving the voted topic higher priority in patching.

Zendesk is still the best way to report bugs.


Please continue to vote guys.

If we can get this toward the top, we might at minimum get feedback in one of the periodic updates they give us on progress. I’d at least like some idea what their thinking is on this.

They don’t plan to update “Garmin” issues until Update 9, some time away. I don’t consider this a “Garmin” issue as it’s pervasive in the sims navigation system, including the airliners MFDs. It’s been broken since release and they clearly intended for it to be a feature from the start. Heck for all we know this issue might not even be fixed as a “Garmin” update and they think it works fine and aircraft always turn around and fly 100nm behind where they are to line up to an imaginary waypoint on approach, at least we might find out.

Exactly, it is a base avionics issue. I would think they would need to fix this before being able to get the Garmin working correctly.

Keep commenting and voting guys. This needs to be fixed ASAP. Last update doesn’t seem to include a fix either.

Not fixed as of Update 6 despite update to NAV and ATC.

I was able to enter an approach in manually though after it tried to send me back.

We need more votes !!!

Anyone got a date for a fix of this bug?

This is a bug in the Navigation within the MCDU for the A320 and a pain in my side. Especially in a go around situation. I have done what is customarily done in the aircraft which program the MCDU for situation, but I still end up being sent all the way back to the entry point for the ILS. What I have been doing is manually flying the miss to a waypoint and then deleting some of the waypoints and using the MCDU to go direct to a waypoint, which works, but a lot of work,

1 Like

As of right now direct to is the only way until it is fixed.

Thanks for the feedback