My 2070 SUPER VR settings and suggestions (Index - SteamVR) 🟢

@stekusteku

This is called “juddering” and there is no way to get rid of this unless you’re natively rendering at your headset refresh rate (for example 90Hz), or you use motion smoothing (which solves juddering but causes wobbling instead…).

Sure enough, motion smoothing eliminates juddering (frame de-doubling/ghosting) which is especially visible for example when looking at the gauges in front of you and moving the head back and forth sideways. However when looking at the wing with the ground passing by underneath, there is a visible distortion of the edges which is a no go visually for me.

Unlike DCS, you’re most often than not flying straight and turning smoothly and I can bear juddering in this case. On the other hand what I don’t like at all is stuttering caused either by the simulator having a hiccup (loading an asset and not enough time for the next frame) or by the simulator always trying to rendering at a fixed integer divisor of the HMD refresh rate. In the later case, it cycles between 30, 40, 45 etc… every frame and this causes stuttering like you get with a monitor not capable of VRR (freesync/g-sync). There is no other way to do because if your monitor is 60Hz and you’re rendering at 40Hz, you’ll have to display frames like this: 1, 2, 2, 3, 4, 4, etc… in order to turn 40 frames into 60 over 1 second. This effect is really visible in the headset. Therefore I’ve tried a different approach: configuring the simulator to force it down to a fixed 30 fps/90Hz and I’ve no stutters in 95% of the time over very dense areas, and nearly none in sparse places where it can lock to 40fps (at 80Hz) or 45fps (at 90Hz).

Amazingly I find even at 30fps, because there is no stutters, this gives me a very smooth and fluid feeling in VR (besides juddering which is unavoidable in this case). I’ve explained this approach in an update post in this discussion.

As for 30fps vs 90fps, I agree the more the merrier if you’re playing HLA and want to avoid a Head Crab jumping on you, or if you want to break a blue box with a light saber with the beat of a tune…

However, what matters the most is not fps but angular velocity of the pixels: if you look forward flying an airplane mostly looking horizontally, the pixels passing by and moving in view are slowly moving only (even if flying 300kts). But if you look side ways they are passing by fast because you’re looking at the pixel in a perpendicular direction.

For these reasons what matters most in Flight Simulation VR is not much fps but smoothness, which is best experienced when you get a regular xx fps value with no spikes. And in this case because the simulator is CPU bound most of the times, it is easier to keep 30fps stable in pushing some of the settings adequately, which is also one of the aspects of fine tuning the settings like I’m explaining in “My VR Settings”!

Of course if you’re doing aerobatics… forget about 30 fps…

Here is a more detailed explanation why 30 fps stable is better than 40 fps varying (and why you rather set Gauge Refresh Rate HIGH in VR).

As for illustrations, I believe there are plenty in the OP isn’t it?

NB: Although some WMR/OXR information is getting into it, this discussion is mainly for SteamVR and the Index. Please wait for my “WMR G2” edition for WMR/OXR specific info and screenshots!

6 Likes

He is using a riftS, so kind of a low resolution headset.
This must help a lot with the fps.
I have a 2080ti, but I’m using a Pimax 8k+, so I’m happy with my 30-37 fps (lod 100%, steam 100%, pimax render 1, almost all other to low or medium).

I dont have 30fps even with lowend and all minimum settings. Seems problem with headset

@CptLucky8
Thank you for such detailed expalnations. Now it’s time for me to put the G2 down and to do some reading:
http://lavalle.pl/vr/
to improve my understanding of the VR basics. There is a chapter there about perception, it will be for me a journey 30 years back to my university time, when I attempted to develop a set of equations to drive 6 DoF flight simulator motion platform using linear optimization - and to be honest I ended cleaning the simulator cabin when the test pilot’s stomach could not bear anymore the discrepancies between motion and vison stimulation :wink:

I will wait for for G2 recommendations.

I hope I will be able to get rid of the effect I observe now when looking sideways - it’s hard to explain, it’s like the plane constantly being stopped by a series of elastic bands and constantly breaking team ca. 1-2 per second. It’s like moving through a sticky fluid, constantly breaking free and the next monement being slowed down again by it. Very distracting.
Plus very annoing effects when looking thorugh C172 propeller ring, impacting even the magnetic compass mounted on the instrument panel, with the sky and the propeller ring as a backgorund. Hard to explain all these visual effects, but you probably know proper names for them.

One final question however, you said “configuring the simulator to force it down to a fixed 30 fps/90Hz”. Are you actually locking 30 FPS in nVidia control panel?

No :slightly_smiling_face:

I’m adjusting the settings so that it is so busy loaded in GPU and so making the CPU waiting adequately, that the FS2020/OXR implementation makes it stick to 30fps (with a headset at 90hz) or 40fps (with a headset at 80hz) :upside_down_face:

Here is what I’ve found during the beta:


It looks like in VR it is trying to lock-on an integer divisor of your refresh rate. I’ve noticed FS2020 is most likely locking to 22.5 fps (90 / 4) when I set the Index to 144Hz or 120Hz, while at the same time it is locking to 30 fps (90 / 3) or 40 fps (80 / 2) when I use 90Hz or 80Hz respectively.

  • with HMD at 90Hz, it will try to lock at 90, 45, 30, 22.7
  • with HMD at 80Hz, it will try to lock at 80, 40, 20

This is why depending on the location, when my system can render a little bit above 40, I prefer lowering the display to 80Hz and have it locked to 40 fps otherwise should I set the HMD to 90hz it would lock to 30fps.

This might be something only OpenXR related, or only FS2020 related though, because I don’t remember any other VR title snapping the fps like this either. Should you have Motion Smoothing enabled (SteamVR) I understand they implement a lock-to fps feature because it would give your the smoothest experience (constant fps) and the best effect (motion smoothing). But it you disable Motion Smoothing and fps varies at will, it would give variable juddering which is not comfortable.

NB: it tries to lock to these divisors even if I disable motion smoothing.

Hey i have read over your 2070 super guide ( i have a 3070, 48GB Ram 3200, i9 9900k)

Disabling Motion Smoothing, as well as using 70 percent TAA, while doing Steam VR res upscalled to 220, i did see a better picture as well as a smoother image…BEFORE rolling back Nvidia Driver to the 460 driver.

After rolling back the driver, I saw a more stable loading screen, with less window snapping/jittering/shaking ( which i just watch to improve my motion sickness resistance, cuz why not?)

I also tried the same settings (70TAA 220SAA in steamVR, NOT in game res which is kept at 100 percent) and it did run alot smoother, but the Rubberbanding/snapping/ UI snapback feeling is still there and even locks up.

Running the game first then CTRL+TAB to go into VR mode DOES seem to give me alot smoother experience( given that you have NOTHING VR related open…windows, UI, steamVR,Viveport…) as well as less jittering on the loading screen)

Game mode and Hardware acceleration are off.

1 Like

I’m still struggling to understand how MSFS VR actually works, because a lot of what I know from other sims especially DCS don’t seem to apply. Perhaps this is due to the OpenXR API which is somehow different or bugs in implementation? Been testing daily with my Index and 9900K/3090 setup using fpsVR. It seems that on my setup, the only way the CPU doesn’t show frametime spike is when I run my Index in 120Hz mode with a goal of targeted fps around 60. With my current setting of Rendering scale 80% and LODs 80, medium/low parameters I can get CPU frametime consistently in the green zone <10ms—but only in 120 Hz mode. With other mode CPU frametime would spike at regular intervals into the yellow zone. This behavior reminds me of running VR with vsync on even though it is off in my setting.

With this mode and current graphic settings, my avg fps per fpsVR is around 58 which is pretty good (for small GA planes). GPU frametime is always in the yellow zone but smooth (in lower Hz modes I get some greens but that results in micro stuttering). Flying around the Empire State Building area gives me mid 50s fps which is not bad. I also tried the OpenXR dev tool vs SteamVR and did not see any difference in performance with my setup, so sticking with default SteamVR setup for now. I sometimes get good FPS in 80 Hz mode but it is not consistent and typically results in more frametime spikes especially on the CPU side.

For me, the recipe for good and smooth fps is Index in 120 Hz, reduced rendering scale as well as LODs, low ambient occlusion, low volumetric clouds. I’m running Stream SS 100% with TAA, motion smoothing off (seems to be overridden by OXR API anyway).

First: OXR Dev Tools has nothing to do with the Index nor SteamVR OpenXR driver. It has only to do with any WMR OpenXR driver.

Having said this there is a known bug with SteamVR and nearly all Nvidia drivers released after 446.14. It is documented by Nvidia release notes, discussed at length in the Nvidia forums (and reddit), and there is nothing you can do but mitigate. Now because you’re running a 3090 you can’t use 446.14, however I don’t know if you can at least use Nvidia drivers 452.06 because if you can with the 3090, I find it is roughly equivalent to 446.14 in terms of VR, slightly better than 457.30 but not much, and way better than 460.xx I’ve tried with the 2070S.

I’m cool with the current performance using my current settings. Just don’t like the way the CPU frametime took a hit from simply lowering the frequency of the headset with no change in other settings. Ideally I would like to run it in 80 Hz mode with targeted fps of 40, while upping other graphic parameters for better image fidelity.

Is there a way to run MS Store Flight Sim in SteamVR mode rather than OpenXR?
I`m not getting good results with OpenXR and a G2, so would like to try Steam.
Thanks for the info anyway, useful thread.

Yes.

Go to settings in steamVR, developer (I think, from memory - it is somewhere in settings though if you look around) and set steam as the open XR runtime

To revert, go to the openXR for wmr developer app and it’ll prompt you to set that as the default openXR runtime.

If you’re going to use steam I’ve found it works best to have steam VR closed, open flight sim and then when you ctrl-tab it’ll open steamVR.

I had slightly worse perf when I tried the G2 on the steam openXR runtime but I think there has been an update since then.

Thanks, but what i mean is i dont have Flight Sim as part of Steam, its a MS Store purchase. It just runs in WMR/OpenXR by default. SteamVR isnt used at all , Can the MS Store Flight Sim be forced to use Steam?

Thanks so much @CptLucky8 ! These settings work very well on my 3090, but suffer the same issues as you discussed (occasional frame skips and poor judder in jet cockpits).

Are you aware of the known nvidia driver issue with Steam VR and Index?

www dot nvidia dot com/en-us/geforce/forums/game-ready-drivers/13/402768/valve-index-missing-dropped-frames-since-nvidia-d/

It would seem until they fix this issue, a lot of your settings might just be a workaround.

The issue dates back further than the drivers that you recommend, so even older drivers might work better. But it does sound like nvidia is working on a complete fix and some of the more recent drivers make it less worse.

1 Like

Yes, the way I told you how to do it will work regardless of where you bought it from and is how I tested it. I also have the windows store version.

I don’t believe which version you have is actually particularly relevant for most things though because the Microsoft store and steam store only contain the launchers which then install and launch the game separately from either platform. Whether you have the steam version or the windows store version should be largely irrelevant.

ah ok, thanks.yes i see now, when i restarted the WMR software now complains that OpenXR isnt set after I changed SteamVR to not use OpenXR.

Guys.,

Yesterday I said that in my case , switching from OpenXR to SteamVR environment gave me a better overall results with my G2.
Well as far as it’s true, I have to admit that when OpenXR is active and locks to that magic 30fps, it is actually really smooth and better than SteamVR environment at higher frame rates (35-45 fps).
This is clearly visible at dynamic turns…
Now my question is simple - if SteamVR is able to give me that constant 35-45fps almost everywhere, why my system is struggling to hit 30fps in OpenXR dev with the same resolution and settings…? I just need that steady 30fps in OpenXR and I’m set…

Eagerly awaiting your G2 results as I continue fiddling with mine. I think I’m nearly at a “set it and forget it” point with quality/performance tradeoff, looking forward to incorporating more of your findings.

Also, is there a place we can send you a beer or coffee or something for your efforts? Thanks.

@paulr70xbox I’ve just posted this information about OXR via Steam or WMR:
https://forums.flightsimulator.com/t/wmr-scaling-and-dev-tools-some-explanations/339477/78

@Radeks40 Thank you for sharing this information. As a matter of fact I always have better results with WMR OXR instead of SteamVR OXR with the G2, but let’s keep this for “My VR Settings - G2” discussion later if you want. I’m interested in exploring these avenues.

@Trowels I thank you for your kind words! If you look at my profile, you’ll see my website…

Once the SDK is incorporating the minimum necessary, the best way to supporting these efforts will be flying with the Reality XP GNS and Reality XP GTN in FS2020 :wink:

1 Like

My best NVidia Driver recommendation for VR (and 2D):

NVidia Card Driver ver. Comments
20XX/30XX 457.30 Best for VR on 3090, 3080 and 20XX
3060 457.51 Best for VR on 3060
any 471.41 good enough to replace the venerable and trusted 457.30!

Tip: When installing NVidia driver, choose “Custom Installation” and select only “Core Driver files” and “NVidia Physics” (deselect all other options and never install GeForce Experience - see below).

NB: The NVidia driver bugs in VR is present with any driver release after 446.14. However I do have the best results with 457.30 which is close to 446.14 and compatible with SW Squadron with any 20XX card. Many other users are also reporting best results with 457.30.

:warning: 457.30 and 457.51 don’t include the latest security fixes unfortunately

More info: Security Bulletin: NVidia GPU Display Driver - January 2021


Here is some of the latest NVidia drivers history:

NVidia Card Driver ver. Comments
20XX 446.14 Last known WDDM 2.6 prior HAGS (recommended by SteamVR)
" 452.06 1st one with FS2020 optimizations (last one without FrameView SDK*)
3090 456.38 min ver required
3080 456.38 min ver required
3070 457.09 min ver required
3060 457.51 min ver required
any 471.41 good enough to replace the venerable and trusted 457.30!

*this is a new SDK shipping with the driver installation, most likely if you install GeForce Experience. Looking at the files it seems it is meant to capturing the VR views and measuring performance (the type you see in the form of graphs with fpsVr) and I believe it has some Vive IP in there. However it seems Nvidia VR problems started since they included this SDK


@Taleeah Thank you for your kind words!

Yes I do know about the Nvidia driver and I’ve already commented in this discussion about it here:
https://forums.flightsimulator.com/t/my-2070-super-vr-settings-and-suggestions-valve-index/321913/40


[update 27JAN2021] I’ve change the warning about the security fixes (thanks @AlexE75)
[update 10AUG2021] Added 471.41

12 Likes

Which settings specifically did you use? Did you change the resolution in SteamVR settings (specifically for MSFS 2020) to 78% resolution? I thought that we’re ignoring SteamVR due to changing the registry to point at the Oculus driver?