VFR Map Losing Route - No Magenta Line

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
Navigraph Subscription
Are you using Developer Mode or made changes in it?
No
Brief description of the issue:
VFR route disappears from VFR Map and also Garmin display. Autopilot will continue to fly the route.
Provide Screenshot(s)/video(s) of the issue encountered:



Detail steps to reproduce the issue encountered:
Nothing special to do. It just does it. Was doing a flight from KSAN to KLAS with a waypoints at Lake Havasu and Hoover Dam. Notice that on second photo the distance from KNRS to Lake Havasu is only 8NM.
PC specs for those who want to assist (if not entered in your profile)

Did you submit this to Zendesk? If so, what is your ticket #?Yes, 99485

Magenta Line Bug SOLVED
Route Line Not showing up on GPS
🛣 The Tōkaidō Road (Tokyo to Kyoto) {Mount Fuji, 3 Official/Modeled POIs, 14+ BTR POIs}
🍇 Rhine River (Germany) {World Update 6, 4 Official/Modeled POIs, 12+ BTR POIs}
🌋 Raven-Flóki Expedition (Iceland) {Reykjavík, 3 Official/Modeled POIs, 9+ BTR POIs}
🛦Million Dollar Ride (Washington, USA) {Mount Rainier, Military Training Route, Cascade Mountains, 9+ BTR POIs}
🦅 The Beltway (Washington DC) {White House, National Mall, 6 Official/Modeled POIs, 18+ BTR POIs}
🚂 Oslo to Bergen Line (Norway) {8 Official/Modeled POIs, 19 BTR POIs}
🦕Great Glen Fault (Highlands of Scotland) {Loch Ness, 1 Official/Modeled POI, 19+ BTR POIs}
🚲Tour de France Stage 10, Raced Earlier Today {Courchevel, 3 Official/Modeled POIs, 8 BTR POIs}
🚢 Exploring the Panama Canal
Magenta line bug?!?
Magenta line bug?!?
PLN not showing in avionics?
⛵ Cape Route (Cape Town) {Cape of Good Hope, 1 Official/Modeled Airport, 19+ BTR POIs}
Dubai Creek & Palm Islands {Burj Khalifa, Downtown Dubai, 5 Official/Modeled POIs, 15+ BTR POIs}
Nile River (Egypt) {Pyramids, Cairo, 7 Official/Modeled POIs, 10+ BTR POIs}
Road of the Seven Lakes (Argentina) {Water Landings, Glacial Lakes/Valleys, 10+ BTR POIs}
🏺 Amalfi Coast (Italy) {Naples, Pompeii, Mt Vesuvius, 15+ BTR POIs}
🦩 The Great Gathering of Lesser Flamingos (Kenya) {Great Rift Valley, Rhinos?, 11 BTR POIs}
🌉 Han River (South Korea) {Seoul, 20+ BTR POIs}
🏄‍♂️ Great Ocean Road (Australia) {Beaches, 18 BTR POIs}
🏙 Hudson River (New York City) {Statue of Liberty, 6 Official/Modeled POIs, 19+ BTR POIs}
Flight Plan missing after returning to bush trip #PC

Someone posted earlier that POI names with greater than six characters as part of a flight plan will cause the Magenta Line to disappear.

3 Likes

That may explain it, third waypoint is LAKE HAVASU CITY and fourth Hoover Dam. I have update the Garmin which now shows the flight plan.

Thanks for the info!

This worked fine before sim update 3 and did not get fixed with the latest update.

3 Likes

Hi, all PLN files I downloaded from the internet show in my in game avionics. I now have created two PLN files myself and while I can load them in the sim no problem they don’t show in game, neither in avionics nor in the VFR map. I cannot see anything in the syntax of these PLN that differs from other PLN files that show up in avionics. Could anyone please help?
Thanks!
8000ers Nepal.PLN (3.7 KB) 8000ers Pakistan.PLN (2.9 KB)

EDIT: the POIs show in the avionics menu but not the plans

Do these plans include POIs (i.e. cities, named tourist spots, fauna etc) and are they six characters or greater in name length?

You can find them attached above. They include custom coordinates with custom IDs - these IDs are longer than 6 characters.

Edit: sample waypoint:

User N28° 35' 51.42",E83° 49' 14.22",+008500.00 -1

Yep. That’s a recently discovered bug. Make the names less than six characters if you can. For fixed POIs in the sim, there’s no workaround. The AP will follow the route, it’s just the Magenta Line will not appear.

1 Like

Super! Thank you. All sorted now.

  • Do not use POI with six characters or more in your flight plan

I did not find the fix for this issue as someone was talking about another related issue importing a flight plan and I have lost the thread and am out of time today. So I will just post the fix in case people missed it and or are still running into the bug which can be frustrating. I tested it and it seems to work so for now I will say solved unless I run into it again.

MODERATOR EDIT: This post was merged into this topic.

Hi,have a new problem,never happen to me,so the magenta line in the vfr map dosnt show up,or at least shows up only the first time in flight,after that,when i finish the flight and i want to make another one,disappered from the vfr map so i have to reboot the sim to flight again and make the vfr map works again.

Hi all! Some posts were merged into this topic. If yours was one of them, you will need to recast your vote as we can not merge votes. Thank you!

@CAPTAINAS007, I’ve modified your title to include “No Magenta Line” to help in searching topics as we were getting duplicates on this. :wink: Thank you much!

have the same problem, when i create a route just from airport to airport on the world map the pink line shows up, but when in cockpit and accessing vfr map drop down, the pink route line is missing. I am using vr flying.

So let me get this straight unless we get more votes this long standing BUG will never be fixed?

Use short waypoint names amd you won’t have any problems. I think the max is six characters.

Before sim update 3 that was not true so that is a regression bug to me.

Yes, it is a bug. But for a lot of us it’s no big deal. Other more important problems to fix. But I understand how it could bother some people.

Anyone of you have an idea related a similar issue?